POJ 2965-The Pilots Brothers' refrigerator(贪心+枚举)

8 篇文章 0 订阅
5 篇文章 0 订阅

The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19464 Accepted: 7462 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

题意:冰箱有16个把手,“+”为关,“-”为开,要想打开冰箱,必须16个把手全部为“-”,每改变一个“+”号该“+”所在的行和列的开关形态都要变化为相反的,问最少多少步能把他全部变为“-”。输出改变的行和列。

思路:[来源orz]---先看一个简单的问题,如何把'+'变成'-'而不改变其他位置上的状态?答案是将该位置(i,j)及位置所在的行(i)和列(j)上所有的handle更新一次。结果该位置被更新了7次,相应行(i)和列(j)的handle被更新了4次,剩下的被更新了2次.被更新偶数次的handle不会造成最终状态的改变.因此得出高效解法,在每次输入碰到'+'的时候, 计算所在行和列的需要改变的次数当输入结束后,遍历数组,所有为奇数的位置则是操作的位置,而奇数位置的个数之和则是最终的操作次数.但这种算法只对n为偶数时适用。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
char a[5][5];
int b[5][5];
int main()
{
        char c;
        int i,j,k;
        int cnt=0;
        memset(b, 0, sizeof(b));
        for (i = 1; i <= 4; i++) {
                for (j = 1; j <= 4; j++) {
                        scanf("%c",&a[i][j]);
                        if(j==4)
                            getchar();
                        if (a[i][j]== '+') {
                                for (k = 1; k <= 4; k++) {
                                        b[i][k]++;
                                        b[k][j]++;
                                }
                                b[i][j]--;//当前把手重复记录了1次,所以要减去;
                        }
                }
        }
        for (i = 1; i <= 4; i++)
                for (j = 1; j <= 4; j++)
                        cnt += b[i][j]%2;
        printf("%d\n",cnt);
        for (i = 1; i <= 4; i++)
                for (j = 1; j <= 4; j++)
                        if  (b[i][j]%2)//翻转偶数次代表没翻转,只有翻转奇数次的才代表翻转
                                printf("%d %d\n",i,j);
        return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值