A == B ?

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2054


Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
  
  
1 2 2 2 3 3 4 3
 

Sample Output
  
  
NO YES YES NO
  
  
题目很水,但交了几次还是错了,一开始我以为是考察对考浮点数的判断,实际上是对字符串的处理,代码如下:
#include<stdio.h>
#include<string.h>
#define N 1000000
char a[N],b[N];
void Trans(char *A,char *goal)
{
    int i,j,len=strlen(A),pos,t,flag=0;
    for(i=0; A[i]=='0'&&i<len; i++);//忽略前导0
    for(j=0; j<len; j++)
        if(A[j]=='.')flag=1;
    j=len-1;
    if(flag)//判读是否有小数点,如果有,忽略后面的0
        for(; A[j]=='0'&&j>=0; j--);
    for(pos=i,t=0; pos<=j; pos++)
        goal[t++]=A[pos];
    if(goal[t-1]=='.')t--;//如果结尾是'.'要去掉
    goal[t]='\0';
}
int main()
{
    char A[N],B[N];
    while(scanf("%s%s",A,B)!=EOF)
    {
        Trans(A,a);
        Trans(B,b);
        if(strcmp(a,b))printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值