ACdream原创群赛(13)のwuyiqi退役专场:LSS

这是一道签到水题

计算最长连续相同字符的个数

http://115.28.76.232/problem?pid=1111


LSS

Time Limit: 20000/10000 MS (Java/Others)  Memory Limit: 128000/64000 KB (Java/Others)
Problem Description

Time flies, four years passed, colleage is over. When I am about to leave, a xuemei ask me an ACM  problem, but I can't solve it, I am 功力尽失.  Please help me so that I won't lose face in front of xuemei!

 

Give you a string , you should find the longest substring which is of the same character. 

Input

First line there is a T , represents the test cases.

next T lines  will be T strings.

the length of every string is less than 100

all the characters of the strings will be lowercase letters

Output

for each test case output a number

Sample Input
1
a
Sample Output
1


测试数据:

2

asdfghkl

aassss

输出:

1

4


<pre name="code" class="cpp">
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 10000+5;
char str[M];
int n;
int ans;
int sum;

int main()
{
    cin>>n;
    while( n-- )
    {
        memset(str, 0, sizeof(str));
        cin>>str;
        ans=0;
        sum=1;
        for(int i=0; i<strlen(str); i++)
            if(str[i]==str[i+1])
            {
                sum++;
            }
            else
            {
                if(ans<sum)
                    ans=sum;
                sum=1;
            }
        cout<<ans<<endl;
    }

    return 0;
}

 

 
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值