HDU:A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 204863    Accepted Submission(s): 39378


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

char a[1001], b[1001], c[1001];
int y=0;

int main()
{
    char s1[1001], s2[1001];
    int t, cas, i, j, len1, len2;
    scanf("%d", &t);
    for(cas=1; cas<=t; cas++)
    {
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        memset(c, 0, sizeof(c));
        cin>>s1>>s2;
        len1 = strlen(s1);
        len2 = strlen(s2);
        for(i=0; i<len1; i++)
            a[len1-i-1] = s1[i]-'0';
        for(i=0; i<len2; i++)
            b[len2-i-1] = s2[i]-'0';
        cout<<"Case "<<cas<<":\n";
        cout<<s1<<" + "<<s2<<" = ";
        if(len1<len2)
            len1 = len2;
        y=0;
        for(i=0;i<len1;i++)
            {
                y+=a[i]+b[i];
                c[i]=y%10+'0';
                y=y/10;
            }
        if(y==1)
            cout<<y;
        for(i=len1-1; i>=0; i--)
            cout<<c[i];
        cout<<endl;
        if(cas<t)
            cout<<endl;
    }
    return 0;
}






#include<iostream>
#include<cstdio>
#include<string.h>
#define N 1005
int main()
{
    int i, j, k, m, l1, l2, t;
    char s1[N], s2[N];
    int a[N], b[N];
    scanf("%d", &t);
    for(m=1; m<=t; m++)
    {
        memset(s1, 0, sizeof(s1));
        memset(s2, 0, sizeof(s2));
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        scanf("%s%s",&s1, &s2);
        l1=strlen(s1);
        l2=strlen(s2);
        if(l1>l2)
            k=l1;
        else
            k=l2;
        for(i=k,j=l1-1; j>=0; i--,j--)
            a[i]=s1[j]-'0';
        for(i=k,j=l2-1; j>=0; i--,j--)
            b[i]=s2[j]-'0';
        for(i=k; i>0; i--)
        {
            a[i]+=b[i];
            if(a[i]>=10)
            {
                a[i]-=10;
                a[i-1]++;
            }
        }
        printf("Case %d:\n%s + %s = ",m,s1,s2);
        if(a[0]!=0)
        {
            for(i=0; i<=k; i++)
            {
                printf("%d",a[i]);
            }
        }
        else
        {
            for(i=1; i<=k; i++)
                printf("%d",a[i]);
        }
        if(m<=t-1)
            printf("\n\n");
        else
            printf("\n");
    }
    return 0;
}



JAVA:第一次用JAVA写程序啊。。
import java.math.BigInteger;
import java.util.Scanner;
public class Main
{
    public static void main(String[] args) 
    {
        Scanner cin = new Scanner(System.in);
        BigInteger a,b,c;
        int t=cin.nextInt();
        for(int i=1;i<=t;++i)
        {
            a=cin.nextBigInteger();
            b=cin.nextBigInteger();
            c=a.add(b);
            System.out.println("Case "+i+":");
            System.out.println(a + " + " + b + " = " +c);
            if(i<t) System.out.println();
        }
    }
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值