POJ 1703:Find them, Catch them(带权的并查集)


Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 30702 Accepted: 9447

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.


题意:

城市里面有2个犯罪团伙,罪犯都属于这两个团伙。现在给你2个罪犯,判断他们是不是一个犯罪团伙。如果当前关系不确定,就输出not sure yet.

并查集的应用,很A bug's life基本一样。



#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cmath>

using namespace std;

const int maxn = 100005;
int cas, n, m;
int parent[maxn], relation[maxn];
char str[2];
int a, b;

int find(int x)
{
    if (x == parent[x])
        return x;
    int px = find(parent[x]);
    relation[x] = ((relation[x] + relation[parent[x]])%2);
    return parent[x] = px;
}

void init()
{
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= n; i++)
    {
        parent[i] = i;
        relation[i] = 0;
    }
}

void kruskal(int a, int b)
{
    if(n==2 && str[0]=='A')
//题意是说只有两个人时,应该是属于不同的团伙。。但是数据没有这个。。就算不加也A了、、
        printf("In different gangs.\n");
        else
        {
            int pa = find(a);
            int pb = find(b);
            if (pa != pb)
            {
                if (str[0] == 'D')
                {
                    parent[pa] = pb;
                    if (relation[b] == 0)
                        relation[pa] = 1 - relation[a];//表示不同
                    else
                        relation[pa] = relation[a];//相同
                }
                else printf("Not sure yet.\n");
            }
            else
            {
                if (str[0] == 'A')
                {
                    if (relation[a] != relation[b])
                        printf("In different gangs.\n");
                    else
                        printf("In the same gang.\n");
                }
            }
        }
}

int main()
{
    scanf("%d", &cas);
    while (cas--)
    {
        init();
        while (m--)
        {
            scanf("%s%d%d", str, &a, &b);
            kruskal(a, b);
        }
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值