HDU 1150 Machine Schedule【最小顶点覆盖】

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6721    Accepted Submission(s): 3370



Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 
 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
  
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
  
  
3
 

Source

题目链接。


题目大意:
有K个工作,每个工作可用A机器的ai模式或者B机器的bi模式完成。A、B机器初始模式为0,每台机器切换模式需要重启。
求最少的重启次数完成工作调度。


解题思路:
最小顶点覆盖。
一个工作可用A或B的不同模式来完成,那么这两种模式之间就存在一条边,边的顶点为对应的两种模式。 
求最少用多少点可以覆盖所有边。即最小顶点覆盖。

 König定理:二分图中的最大匹配数等于这个图中的最小点覆盖数。

给出一个这个定理的证明的博文 --->>> 二分图最大匹配的König定理及其证明

#include <cstdio>
#include <cstring>
const int maxn = 110;
bool job[maxn][maxn],used[maxn];
int b[maxn];
int n,m,k;
void init()
{
	int i,j,x,y;
	memset(job,0,sizeof(job));
	memset(b,0,sizeof(b));	//B机器初始化
	for(i=0;i<k;++i)
	{
		scanf("%d%d%d",&j,&x,&y);
		job[x][y]=true;
	}
}
bool find(int p)
{
	int i;
	for(i=1;i<=m;++i)	//扫描B机器 
	{
		if(job[p][i]==true&&!used[i])
		{
			used[i]=true;
			if(b[i]==0||find(b[i]))
			{
				b[i]=p;
				return true;
			}
		}
	}
	return false;
}
int main()
{
	int i,restar;
	while(scanf("%d",&n),n)
	{
		scanf("%d%d",&m,&k);
		init();
		restar=0;
		for(i=1;i<=n;++i)		//扫描A机器 
		{
			memset(used,0,sizeof(used));
			if(find(i))
				restar++;
		}
		printf("%d\n",restar);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值