D-We Love MOE Girls

D - We Love MOE Girls
Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them.  
In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu".  
There are two situations:  
If a sentence ends with "desu", she changes "desu" into "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence.  
Given an original sentence, what will it sound like aften spoken by Nanako?
 

Input

The first line has a number T (T <= 1000) , indicating the number of test cases.  
For each test case, the only line contains a string s, which is the original sentence.  
The length of sentence s will not exceed 100, and the sentence contains lowercase letters from a to z only.
 

Output

For every case, you should output "Case #t: " at first, without quotes. The   t  is the case number starting from 1. Then output which Nanako will say.
 

Sample Input

       
       
2 ohayougozaimasu daijyoubudesu
 

Sample Output

       
       
Case #1: ohayougozaimasunanodesu Case #2: daijyoubunanodesu
 
#include<stdio.h>
#include<string.h>
int main()
{
    int T, len, i, j;
    char s[102];
    scanf("%d", &T);
   for(j=1; j<=T;j++)
    {
        scanf("%s", s);
        len = strlen(s);
        if( s[len-4]=='d' && s[len-3]=='e' && s[len-2]=='s' && s[len-1]=='u')
        {
            printf("Case #%d: ", j);
            for(i=0;i<(len-4); i++)
                printf("%c", s[i]);
            printf("nanodesu\n");
        }
        else
        {
            printf("Case #%d: ", j);
            for(i=0; i<len; i++)
                printf("%c", s[i]);
            printf("nanodesu\n");
        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值