poj1964 City Game(最大子矩阵)

                                                                  City Game
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 4783 Accepted: 1899

Description

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.
Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you're building stands is 3$.
Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input

The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:
R – reserved unit
F – free unit
In the end of each area description there is a separating line.

Output

For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output

45
0

这个题是lrj大白上的一个例题。

 思路:


代码:

#include<stdio.h>
#include<string.h>
#define max(a, b) (a>b?a:b)
#define min(a, b) (a<b?a:b)
int map[1005][1005], up[1005][1005], left[1005][1005], right[1005][1005];//要开全局变量,在main里会超

int main()
{
    int T, n, m, i, j, lo, ro, ans;
    scanf("%d", &T);
    while(T--)
    {
        ans = 0;//注意初始化
        memset(map, 0, sizeof(map));
        memset(up, 0, sizeof(up));
        memset(left, 0, sizeof(left));
        memset(right, 0, sizeof(right));
        scanf("%d%d", &n, &m);//n行,m列
        for(i=0; i<n; i++)
           for(j=0; j<m; j++)
           {
               char ch = getchar();
               while(ch!='F' && ch!='R') ch = getchar();//两个字母之间可能有多个空格
               map[i][j] = ch == 'F'? 0:1;//用0表示F, 1表示R
           }

        for(i=0; i<n; i++)
        {
            lo = -1; ro = m;//每扫一行,初始化一下。
            for(j=0; j<m; j++)
            {
                if(map[i][j]==1) {up[i][j]=left[i][j]=0; lo=j;}
                else
                {
                    up[i][j] = i==0 ? 1 : up[i-1][j]+1;
                    left[i][j] = i==0 ? lo+1 : max(left[i-1][j], lo+1);
                }
            }
            for(j=m-1; j>=0; j--)
            {
                if(map[i][j]==1) {right[i][j]=m; ro=j;}
                else
                {
                    right[i][j] = i==0 ? ro-1 : min(right[i-1][j], ro-1);
                    ans = max(ans, up[i][j]*(right[i][j]-left[i][j]+1));//当某一行的up和left扫完后,每扫一个right点
                                                                         //都要计算一遍面积,和ans比较,取最大值。
                }
            }
        }
        printf("%d\n", ans*3);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值