BestCoder Round #11 (Div. 2)--Bob and math problem

Bob and math problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 965    Accepted Submission(s): 370


Problem Description
Recently, Bob has been thinking about a math problem.
There are N Digits, each digit is between 0 and 9. You need to use this N Digits to constitute an Integer.
This Integer needs to satisfy the following conditions:
  • 1. must be an odd Integer.
  • 2. there is no leading zero.
  • 3. find the biggest one which is satisfied 1, 2.

Example: 
There are three Digits: 0, 1, 3. It can constitute six number of Integers. Only "301", "103" is legal, while "130", "310", "013", "031" is illegal. The biggest one of odd Integer is "301".
 

Input
There are multiple test cases. Please process till EOF.
Each case starts with a line containing an integer N ( 1 <= N <= 100 ).
The second line contains N Digits which indicate the digit $a_1, a_2, a_3, \cdots, a_n. ( 0 \leq a_i \leq 9)$.
 

Output
The output of each test case of a line. If you can constitute an Integer which is satisfied above conditions, please output the biggest one. Otherwise, output "-1" instead.
 

Sample Input
  
  
3 0 1 3 3 5 4 2 3 2 4 6
 

Sample Output
  
  
301 425 -1
 

Source


题意:给n个数字,然后按要求组成一个数。
            要求:1. 必须为奇数。
                        2. 必须包含数字1,或者2
                        3. 数字的开头不能为0,比如021(错误,输出-1)

算法:
         首先找到一个最小的奇数,记录下表。放在s[0]的位置, 然后从s+1~s+n, 排序,输出即可。这里需要注意的是,当s[n-1] == 0时,应直接输出-1。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int s[1000];
int main()
{
	int t, i, n, tt, pos = 0;
	while(~scanf("%d", &n))
	{
		t = 1000;
		for(i=0; i<n; i++)
		{
			scanf("%d", &s[i]);
			if(s[i]%2==1 && s[i] < t)
			{
				t = s[i];
			    pos = i;
			}
		}
		if(t==1000)
		{
			printf("-1\n");
			continue;
		}
		tt = s[0];
		s[0] = s[pos];
		s[pos] = tt;

		sort(s+1, s+n);
		if(s[n-1] == 0)//这里有个坑,必须判断前导是否为0
		{
		   printf("-1\n");
		   continue;
		}
		for(i=n-1; i>=1; i--)
		{
			printf("%d", s[i]);
		}
		printf("%d\n", t);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值