Counterfeit Dollar

Counterfeit Dollar

时间限制(普通/Java):3000MS/10000MS          运行内存限制:65536KByte
总提交:42            测试通过:19

描述

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

输入

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

输出

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

样例输入

1
ABCD EFGH even
ABCI EFJK up
ABIJ EFGH even

样例输出

K is the counterfeit coin and it is light. 


#include<iostream>
using std::cin;
using std::cout;
using std::endl;
#include<cstring>
#include<cstdlib>

#define MAX_COIN_NUMBER 12
#define MAX_RESULT_LENGTH 5
#define MAX_CASE_NUMBER 3

struct Case{
	char left[MAX_COIN_NUMBER];
	char right[MAX_COIN_NUMBER];
	char result[MAX_RESULT_LENGTH];
};

int coinWeight[MAX_COIN_NUMBER];
Case coinCase[MAX_CASE_NUMBER];
bool hasAppear[MAX_COIN_NUMBER];

void setAppear(const char* s){
	for (size_t ix = 0; s[ix] != '\0'; ++ix){
		hasAppear[s[ix] - 'A'] = true;
	}
}

void setCase(void){
	memset(hasAppear, false, sizeof(hasAppear));
	for (size_t ix = 0; ix != MAX_CASE_NUMBER; ++ix){
		cin >> coinCase[ix].left >> coinCase[ix].right >> coinCase[ix].result;
		setAppear(coinCase[ix].left);
		setAppear(coinCase[ix].right);
	}
}

int weight(const char* coinHeap){
	int sum = 0;
	for (size_t ix = 0; coinHeap[ix] != '\0'; ++ix){
		sum += coinWeight[coinHeap[ix] - 'A'];
	}
	return sum;
}

bool isFitThisCase(const Case& _case){
	int leftWeight = weight(_case.left);
	int rightWeight = weight(_case.right);
	return (leftWeight == rightWeight && strcmp(_case.result, "even") == 0)
		|| (leftWeight < rightWeight && strcmp(_case.result, "down") == 0)
		|| (leftWeight > rightWeight && strcmp(_case.result, "up") == 0);
}

bool isFit(void){
	for (size_t ix = 0; ix != MAX_CASE_NUMBER; ++ix){
		if (!isFitThisCase(coinCase[ix])){
			return false;
		}
	}
	return true;
}

void printResult(void){
	memset(coinWeight, 0, sizeof(coinWeight));
	for (size_t ix = 0; ix != MAX_COIN_NUMBER; ++ix){
		if (hasAppear[ix]){
			coinWeight[ix] = -1;
			if (isFit()){
				cout << char('A' + ix) << " is the counterfeit coin and it is light." << endl;
				break;
			}
			coinWeight[ix] = 1;
			if (isFit()){
				cout << char('A' + ix) << " is the counterfeit coin and it is heavy." << endl;
				break;
			}
			coinWeight[ix] = 0;
		}
	}
}

int main(void){
	unsigned int testTimes;
	cin >> testTimes;
	while (testTimes--){
		setCase();
		printResult();
	}
	return EXIT_SUCCESS;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值