DA SHU

   

import    java.math.BigInteger;
  import    java.util.Scanner;
  public class{
   public  static void  main(string[],args){
   Scanner  cin=new  Scanner (System.in)
   BigInteger   a,b,c;
   int   t=cin.nextInt ();
  for(int i=1;i<=t;i++)
{
     c=a.add(b);
     System.out.println("Case "+i+":");
   System.out.print(a+"+"+b+"="+c);
     if(t>i)           System.out.print();
}
}
}

 

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 204922    Accepted Submission(s): 39391


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
  

# include<iostream>
 # include<cstring>
 using namespace std;
 const int maxn=1000+5;
 char a[maxn],b[maxn],c[maxn];
 int main()
 {
      int n,f,t1,t2,p,i;
      cin>>n;
      f=1;
      while(n--)
      {
         if(f>1) cout<<endl<<endl;
         cin>>a>>b;
         memset(c,'\0',sizeof(c));
         p=0;
         t1=strlen(a)-1;
         t2=strlen(b)-1;
         for(i=0;t1>=0||t2>=0;i++,t1--,t2--)
         {
             if(t1>=0&&t2>=0)  c[i]=a[t1]+b[t2]-'0'+p;
             if(t1<0&&t2>=0)   c[i]=b[t2]+p;
             if(t1>=0&&t2<0)   c[i]=a[t1]+p;
             p=0;
             if(c[i]>'9') {c[i]-=10;p=1;}
         }
         if(p==1)  c[i]='1';
         cout<<"Case "<<f++<<":"<<endl;
         cout<<a<<" + "<<b<<" = ";
         t1=strlen(c)-1;
         while(t1>=0)
            cout<<c[t1--];
      }
     cout<<endl;
     return 0;
 }






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值