Trees on the level

Background

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.

The Problem

Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree

picture28

is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

The Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

The Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete
#include <cstdio>
#include <cstring>
#include <queue>
#include <cstdlib>

using namespace std;

const int MAXN = 300;

struct Node
{
    int have_value;
    int v;
    Node *left, *right;           // 指向结点类型的指针;
};

Node *root;

char s[MAXN + 10];
short failed;
int ans[MAXN];
int n;

Node *newnode();
int read_input();
void addnode(int v, char *s);
void remove_tree(Node *u);
int bfs();

int main()
{

    while (read_input()) {
        if (failed) {
            printf("not complete\n");
            continue;
        }

        int res = bfs();
        if (!res)
            printf("not complete\n");
        else {
            for (int i = 0; i < n; i++) {
                if (i)                            //格式输出值得借鉴
                    printf(" ");  
                printf("%d", ans[i]);
            }
            printf("\n");
        }

        remove_tree(root);     
    }
    return 0;
}


int read_input()
{
    failed = 0;
    root = newnode();

    while(1){
        if (scanf("%s", s) != 1)
            return 0;

        if (strcmp(s, "()") == 0)
            break;

        int v;
        sscanf(&s[1], "%d", &v);            //    得到字符串中的数字;
        addnode(v, strchr(s, ',') + 1);     //strchr()  返回‘,’的指针;
    }

    return 1;
}

Node *newnode()                     // 建立新结点;              
{
    Node *u = (Node*)malloc(sizeof(Node));          //动态分配内存
    if (u != NULL) {
        u->have_value = 0;                   //->  指针指向结构体变量
        u->left = u->right = NULL;
    }

    return u;
}

void addnode(int v, char *s)                   //建立二叉树;     
{
    int len = strlen(s);
    Node *u = root;
    for (int i = 0; i < len; i++) {
        if (s[i] == 'L') {
            if (u->left == NULL) u->left = newnode();
            u = u->left;
        } else if (s[i] == 'R') {
            if (u->right == NULL) u->right = newnode();
            u = u->right;
        }
    }

    if (u->have_value) failed = 1;
    u->have_value = 1;                    //标记结点
    u->v = v;
}

void remove_tree(Node *u)                // 释放这棵树所占内存,防止内存泄露 (memory leak)
{
    if (u == NULL) return;

    remove_tree(u->left);
    remove_tree(u->right);

     delete  u;                           //  释放内存
}

int bfs()                                     //宽度优先遍历二叉树
{
    queue<Node*> q;
    n = 0;

    q.push(root);

    while (!q.empty()) {
        Node *cur = q.front(); q.pop();
        if (!cur->have_value)
            return 0;

        ans[n++] = cur->v;

        if (cur->left) q.push(cur->left);
        if (cur->right) q.push(cur->right);
    }

    return 1;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值