10055 - Hashmat the Brave Warrior

UVa第一题如此简单,三遍才通过。
错误:题中说了“These two numbers in each line denotes the number soldiers in Hashmat’s army and his opponent’s army or vice versa.”所以这两个数相减时应该输出绝对值!不要被“Hashmat’s soldier number is never greater than his opponent.”这句话误导了。


题目:

Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before Fighting he just calculates one thing, the difference between his soldier number and the opponent’s soldier number. From this difference he decides whether to fight or not. Hashmat’s soldier number is never greater than his opponent.
Input
The input contains two numbers in every line. These two numbers in each line denotes the number soldiers in Hashmat’s army and his opponent’s army or vice versa. The input numbers are not greater than 232. Input is terminated by ‘End of File’.
Output
For each line of input, print the difference of number of soldiers between Hashmat’s army and his opponent’s army. Each output should be in seperate line.
Sample Input
10 12
10 14
100 200
Sample Output
2
4 100


代码

#include <stdio.h>

int main() {
    long long mine, oppenent;

    while (scanf("%lld%lld", &mine, &oppenent) == 2) {
        if (mine < oppenent)
            printf("%lld\n", oppenent - mine);
        else
            printf("%lld\n", mine - oppenent);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值