414 - Machined Surfaces

他们都说这是一道水题,我不觉得啊……
还几遍才通过…….

错误主要在于输入输出上,scanf在这题中不可取,因为输入一行中包含了空格!gets最好不用,所以最后用了getchar()对每一个字符进行判断,没读到一个’\n’就输入换行。

最后的答案没有问题的是:sum - minSpace * N
因为很明显的,如果两个表面要接触,只能是突出部位最长的接触(空格最少),剩下的空间就是原来的空格减去了这部分因为接触而消失的空格。

另外还要注意,例子中用了B代替空格,注意代码中要写空格,而不是B!


题目:

An imaging device furnishes digital images of two machined surfaces that eventually will be assembled in contact with each other. The roughness of this final contact is to be estimated.

A digital image is composed of the two characters, “X” and ” ” (space). There are always 25 columns to an image, but the number of rows, N, is variable. Column one (1) will always have an “X” in it and will be part of the left surface. The left surface can extend to the right from column one (1) as contiguous X’s.

Similarly, column 25 will always have an “X” in it and will be part of the right surface. The right surface can extend to the left from column 25 as contiguous X’s.

In each row of the image, there can be zero or more space characters separating the left surface from the right surface. There will never be more than a single blank region in any row.

For each image given, you are to determine the total void" that will exist after the left surface has been brought into contact with the right surface. Thevoid” is the total count of the spaces that remains between the left and right surfaces after theyhave been brought into contact.

The two surfaces are brought into contact by displacing them strictly horizontally towards each other until a rightmost “X” of the left surface of some row is immediately to the left of the leftmost “X” of the right surface of that row. There is no rotation or twisting of these two surfaces as they are brought into contact; they remain rigid, and only move horizontally.

Note: The original image may show the two surfaces already in contact, in which case no displacement enters into the contact roughness estimation.

Input

The input consists of a series of digital images. Each image data set has the following format:

First line -
A single unsigned integer, N, with value greater than zero (0) and less than 13. The first digit of N will be the first character on a line.
Next N lines -
Each line has exactly 25 characters; one or more X’s, then zero or more spaces, then one or more X’s.
The end of data is signaled by a null data set having a zero on the first line of an image data set and no further data.

Output

For each image you receive as a data set, you are to reply with the total void (count of spaces remaining after the surfaces are brought into contact). Use the default output for a single integer on a line.

Sample Input (character “B” for ease of reading. The actual input file will use the ASCII-space character, not “B”).

4
XXXXBBBBBBBBBBBBBBBBXXXXX
XXXBBBBBBBBBBBBBBBXXXXXXX
XXXXXBBBBBBBBBBBBBBBBXXXX
XXBBBBBBBBBBBBBBBBBXXXXXX
2
XXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXX
1
XXXXXXXXXBBBBBBBBBBBBBBXX
0

Sample Output

4
0
0


代码:

#include <stdio.h>
char surface[13 + 10][25 + 10];

int main() {
    int N;

    while (scanf("%d", &N) && N) {
        getchar();
        char c;
        int sum = 0, minSpace = 25;
        for (int i = 0; i < N; ++i) {
            int localSpace = 0;
            for (int j = 0; ; ++j) {
                c = getchar();
                if (c == '\n') break;
                else {
                    if (c == ' ') localSpace++;
                    surface[i][j] = c;
                }
            }
            sum += localSpace;
            if (localSpace < minSpace)
                minSpace = localSpace;
        }
        printf("%d\n", sum - minSpace*N);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值