POJ【1909】数论

Description

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below. 
1/1 1/2 1/3 1/4 1/5 ...

2/1 2/2 2/3 2/4 
3/1 3/2 3/3 
4/1 4/2 
5/1 

In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

Input

The input list contains a single number per line and will be terminated by endof-file.

Output

You are to write a program that will read a list of numbers in the range from 1 to 10^7 and will print for each number the corresponding term in Cantor's enumeration as given below.

Sample Input

3
14
7

Sample Output

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4


 
  

对i累积求和,找到最靠近n并且<=n的一个数,判断它的下一条斜线是奇线是偶线,然后开始一个偶{x=i(自增),y=i(递减)},奇反之。
 
  
code:
#include<stdio.h>
int main()
{
	int i,j,k,n;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
		{
			printf("TERM 0 IS 0/0\n");
			continue;
		}
		int sum=0;
		for(i=1;;i++)
		{
			sum+=i;
			if(sum>=n)
				break;
		}
		sum=sum-i;
		i=i-1;
		j=n-sum;
		if(i%2==1)
		{
			printf("TERM %d IS %d/%d\n",n,j,i-j+2);
		}
		else
		{
			printf("TERM %d IS %d/%d\n",n,i-j+2,j);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值