EASY_PAT_ZJU_1046 求循环数字公路中两个出口的最短距离

1046. Shortest Distance (20)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
NOTE:
问题可变为 循环数组中两个特定数字之间的差距这种问题。
刚开始做的时候,用完全模拟的方式,超时。后来上网看了看别人的思路,顿时明白发现原来可以不用这样。例如,知道了1,2,3,4,5这几个口之间的距离,那么通过叠加,就可以知道
<1,1> = X0;
<1,2> = X2;
...
<1,N> = XN-1;
<1,1+> = XN;
那么,显然从<a,b>d的距离就是<1,b> - <1,a>如果<a>b>那么交换一下就可以了,然后,因为是循环的圈,所以两个方向都是可以的,3->5可以是3,4,5也可以是5,6,7,8,...0,1,2,3这两个值显然是互补的。所以求出一个,就可以知道另外一个。
AC代码:
/*************************************************************************************888/

  @	AUTHOR		: GAOMINQUAN
  @ DATA		: 2014 - 2 - 25
  @ MAIL		: ENSOLEILLY@GMAIL.COM
  @ HARD		: EASY** BUT IF WANNA GET TOTAL SCORE THE HARD I THINK WILL INCREASE TO ***

******************************************************************************************/

#include<iostream>
#include<vector>
using namespace std;

int main(){
	int M = 3, N = 0;
	vector<int> length2Head;
	cin>>M;
	
	length2Head.push_back(0); // <1,1> is zero;
	for(int i = 1; i<=M; i++){
		int temp;
		cin>>temp;
		temp += length2Head[i-1];
		length2Head.push_back(temp);
	}// last elements is total length of roads
	
	cin>>N;
	while(N--){
		int a1,a2;
		scanf("%d %d",&a1,&a2);
		if(a1 > a2) swap(a1,a2);

		int way1 = 0, way2 = 0,shortest = 0;
		
		way1 = length2Head[a2-1] - length2Head[a1-1];
		way2 = length2Head[M] - way1;
		
		shortest = way1<way2?way1:way2;
		
		cout<<shortest<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值