EASY_PAT_ADVANCED LEVEL 1058 A+B IN HOGWART 不同进制数字的加法运算

1058. A+B in Hogwarts (20)

时间限制
50 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
/*
	@ AUTHOR	:GAOMINQUAN
	@ DATA		:2014 - 2- 25
	@ MAIL		:ENSOLEILLY@GMAIL.COM
	@ HARD		:EASY **
	@ NOTE		:NITICE THE USE OF ISDIGIT(), WHICH COULD MAKE PRO WORK EASIER
*/



#include<iostream>
#include<vector>
#include<string>
#include<cmath>

using namespace std;

vector<int> add_2_vec(vector<int> num1,vector<int> num2){
	int tenExp = (int)10e7;
	int biggest[] = {tenExp,17,29};
	vector<int> ans(3,0);
	int addBits = 0;
	for(int i = num1.size()-1; i>=0; i--){
		//cout<<num1[i]<<" "<<num2[i]<<endl;
		int bitSum = num1[i] + num2[i] + addBits;
		//cout<<"BS = "<<bitSum<<endl;
		addBits = bitSum/biggest[i];
		bitSum %= biggest[i];
		
		ans[i] = bitSum;
	}
	return ans;
}

vector<int> input_to_num_vec(string input){
	char node = '.';
	int findNum = 0;
	
	int begin = 0;
	vector<int> numbers(3,0);
	
	int numI = 0;
	
	int numNum = 2;
	for(int i = input.size()-1; i>=0; i--){
		if(isdigit(input[i])){
			//cout<<input[i]<<" is a digit "<<endl;
			findNum += (input[i] - '0') * pow(10,numI);
			numI++;
		}else{
			numI = 0;
			numbers[numNum--] = findNum;
			findNum = 0;
		}
	}
	numbers[0] = findNum;

	return numbers;
}

void add(string input1, string input2){
	vector<int> num1 = input_to_num_vec(input1);
	vector<int> num2 = input_to_num_vec(input2);
	vector<int> add = add_2_vec(num1,num2);
	for(int i = 0; i <add.size(); i++){
		cout<<add[i];
		if(i!=add.size()-1){
			cout<<".";
		}
	}cout<<endl;
}
int main(){
	string input1,input2;
	cin>>input1>>input2;
	add(input1,input2);
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值