POJ 2229-Sumsets ( 基础DP)

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

看了题解才会的题0.0...神奇的DP..

本题分为两种情况, 奇数和偶数.

使用数组dp[] 记录有几种组合..

1 奇数 dp[n]=dp[n-1]..这种情况自己想的到..

2 偶数n :a. dp[n] 的一部分是 dp[n-2] , 即再加上两个1 的情况.. //分解式中有1的情况

                b. 另一部分是 dp[n/2], 即没有 1 的情况, 将 n/2 中的组合乘以 2 即可...//分解式中没有1的情况

15.5.28

重新DP,写出来了=v=,

CODE:

#include <iostream>
#include<stdio.h>
using namespace std;
const int M=1000000000;
int dp[1000005];
int main()
{
    int n;
    dp[0]=dp[1]=1;
    scanf("%d",&n);
    for(int i=2;i<=n;i++)
    {
        if(i%2==1) dp[i]=dp[i-1];
        else dp[i]=(dp[i-2]+dp[i/2])%M;
    }
    printf("%d\n",dp[n]);
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值