HDU 1907- John(NImm博弈)

Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

Sample Input
  
  
2 3 3 5 1 1 1
 

Sample Output
  
  
John Brother

                                                                     

题意:

有n 堆石子,每堆石子有m 个,两个人轮流取石子,任选一堆至少取一个石子。取完后石子没有了则那个人输。

思路:

Nimm 博弈~设一堆中仅有1个石子则称为孤单态s1,大于等于2个石子则为充裕态s2,所有石子总数异或的结果为ans。

先者必输:ans=0 , s2=0;ans !=0,s2!=0

后者必输:ans=0,s2>=0;ans!=0,s1%2!=0,s2=0

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

int main()
{
    int T;
    scanf("%d", &T);
    while(T--){
        int n;
        scanf("%d", &n);
        int a, s1=0, s2=0, ans=0;
        for(int i=0; i<n; i++){
            scanf("%d", &a);
            if(a >= 2) s2 ++;
            else s1 ++;
            ans ^= a;
        }
        if((s2 == 0 & (s1%2 != 0) && ans != 0) || (ans == 0 && s2 >= 2)) printf("Brother\n");
        else if((ans == 0 && s2 == 0) || (ans != 0 && s2 != 0)) printf("John\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值