USACO 1.2 Milking Cows(暴力枚举)

Three farmers rise at 5 am each morning and head for the barnto milk three cows. The first farmer begins milking his cow at time300 (measured in seconds after 5 am) and ends at time 1000. Thesecond farmer begins at time 700 and ends at time 1200. The thirdfarmer begins at time 1500 and ends at time 2100. The longestcontinuous time during which at least one farmer was milking a cowwas 900 seconds (from 300 to 1200). The longest time no milking wasdone, between the beginning and the ending of all milking, was 300seconds (1500 minus 1200).

Your job is to write a program that will examine a list ofbeginning and ending times for N (1 <= N <= 5000) farmersmilking N cows and compute (in seconds):

  • The longest time interval at least one cow was milked.
  • The longest time interval (after milking starts) during whichno cows were being milked.

PROGRAM NAME: milk2

INPUT FORMAT

Line 1:The single integer
Lines 2..N+1:Two non-negative integers lessthan 1,000,000, respectively the starting and ending time in secondsafter 0500

SAMPLE INPUT (file milk2.in)

3
300 1000
700 1200
1500 2100

OUTPUT FORMAT

A single line with two integers that represent the longestcontinuous time of milking and the longest idle time.

SAMPLE OUTPUT (file milk2.out)

900 300

                                                    

题意:

输出n个人挤牛奶的时间区间,求得最长挤牛奶的时间和最长空闲时间。

思路;

按照开始时间从小到大排序,循环一遍,不断更新结束时间的最大值,和工作最长区间和空闲最长区间。

CODE:

/*
ID:sotifis3
LANG:C++
TASK:milk2
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

struct node
{
    int a, b;
}m[5005];

bool cmp(node x, node y)
{
    if(x.a == y.a) return x.b < y.b;
    return x.a < y.a;
}

int main()
{
    //freopen("in", "r", stdin);
    freopen("milk2.in","r",stdin);
    freopen("milk2.out","w",stdout);
    int n;
    while(~scanf("%d", &n)){
        for(int i = 0; i < n; ++i){
            scanf("%d %d", &m[i].a, &m[i].b);
        }
        sort(m, m + n, cmp);
        int t1 = 0, t2 = 0, t = 0, maxn = m[0].b;
        for(int i = 1; i < n; ++i){
            if(maxn >= m[i].a){
                maxn = max(maxn, m[i].b);
            }
            else if(maxn < m[i].a){
                t1 = max(t1, maxn - m[t].a);
                t2 = max(t2, m[i].a - maxn);
                t = i;
                maxn = m[t].b;
            }
        }
        printf("%d %d\n", max(maxn - m[t].a, t1), t2);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值