CSU 1529 - Equator(双端队列)

题目:

Description

Input

Output

Sample Input

3
3 1 2 3
8 4 5 -1 -1 1 -1 -1 5
2 -1 -1

Sample Output

6
14
0
题意:

循环序列,求出最大的子串和。

思路:

双端队列,。

维护一个不大于n的队列,队尾减队首更新答案。

AC.

#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;
const int INF = 1e5;
const int maxn = 1e6+5;
int a[maxn*2], sum[maxn*2];
int deq[maxn*2];

int main()
{
    //freopen("in", "r", stdin);
    int T;
    scanf("%d", &T);
    while(T--) {
        int n;
        scanf("%d", &n);
        sum[0] = 0;
        for(int i = 1; i <= n; ++i) {
            scanf("%d", &a[i]);
            a[i+n] = a[i];
            sum[i] = sum[i-1] + a[i];
        }
        for(int i = n+1; i <= 2*n; ++i) {
            sum[i] = sum[i-1] + a[i];
        }
        int ans = 0;
        deq[0] = 0;
        int s = 0, t = -1;
        for(int i = 1; i <= 2*n; ++i) {
            while(s <= t && sum[i] < sum[deq[t]]) {
                ans = max(ans, sum[deq[t]] - sum[deq[s]]);
                t--;
            }

            while(s <= t && i - deq[s] > n) {
                ans = max(ans, sum[deq[t]] - sum[deq[s]]);
                s++;
            }
            deq[++t] = i;
        }

        ans = max(ans, sum[deq[t]] - sum[deq[s]]);
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值