POJ 2159 Ancient Cipher(水题)

Ancient Cipher
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27998 Accepted: 9185

Description

Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher. 
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from 'A' to 'Y' to the next ones in the alphabet, and changes 'Z' to 'A', to the message "VICTORIOUS" one gets the message "WJDUPSJPVT". 
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation <2, 1, 5, 4, 3, 7, 6, 10, 9, 8> to the message "VICTORIOUS" one gets the message "IVOTCIRSUO". 
It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message "VICTORIOUS" with the combination of the ciphers described above one gets the message "JWPUDJSTVP". 
Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.

Input

Input contains two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet. 
The lengths of both lines of the input are equal and do not exceed 100.

Output

Output "YES" if the message on the first line of the input file could be the result of encrypting the message on the second line, or "NO" in the other case.

Sample Input

JWPUDJSTVP
VICTORIOUS

Sample Output

YES


题意:

对一行字符串进行下列操作:1.每个字符都向后移动N个位置头接尾循环,比如要是向后面移动3位的话,A变为D,E变为H,Z变为C,这里注意的是题目中的例子移动了一位,但是题目要求不一定移动一位(在这里WA了好多次、、、);2,对字符串任意排序;


题解:

这里因为我们不知道题中的移动位数还有排序顺序,所以一看这题感觉无下从下手的感觉,但是仔细想想,不管怎么操作,变化前后字符串里同样的字符出现的个数是不变的,那我们完全可以比较每一串中同样的字符的个数就好了,代码见下面:


题目链接:http://poj.org/problem?id=2159


代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<map>
#include<set>
#include<algorithm>
using namespace std;

const int N=110;

int main(){
	char str[N],st[N];
    int cnt1[30],cnt2[30];
    gets(str);
    gets(st);
    memset(cnt1,0,sizeof(cnt1));
    memset(cnt2,0,sizeof(cnt2));
    int len=strlen(st);
    for(int i=0;i<len;i++){
        cnt1[str[i]-'A']++;
        cnt2[st[i]-'A']++;
    }
    sort(cnt1,cnt1+26);
    sort(cnt2,cnt2+26);
    for(int i=0;i<26;i++){
        if(cnt1[i]!=cnt2[i]){
            printf("NO\n");
            return 0;
        }
    }
    printf("YES\n");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值