POJ 1083 Moving Tables(水题)

Moving Tables
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 25912 Accepted: 8622

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20

30

题意:

按照上图的房间分布,公司里要搬桌子,题中给出搬桌子的区间,相互之间可能有冲突,每搬一次需要10分钟,问至少需要多少分钟,比如:1-3和3-5会冲突,1-3和4-6会冲突,1-5和4-7会冲突,求至少需要多少分钟,才能将桌子搬完,不冲突的可以一次搬完 题解: 因为题中的房间号位置有些特殊,即单号和双号是相对的,并且相对的房间中奇号小于双号,所以可以看做只在双号房间上搬桌子,要是给出奇号只需把奇号+1即可,然后每给一个区间就办相应的小区间+1,最后看数组中的最大值即为要求的最大次数,再讲次数加一就是答案了 题目链接: http://poj.org/problem?id=1083
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<set>
#define ERR "***here***"
using namespace std;
const int N = 220;

int tab[N];

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        memset(tab,0,sizeof(tab));
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            int a,b;
            scanf("%d %d",&a,&b);
            if(a&1) a++;
            if(b&1) b++;
            a/=2,b/=2;
            if(a>b) swap(a,b);
            for(int j=a;j<=b;j++){
                tab[j]++;
            }
        }
        int ans=-1;
        for(int i=1;i<=200;i++){
            if(tab[i]>ans) ans=tab[i];
        }
        printf("%d\n",ans*10);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值