POJ1384-PiggyBank

题目描述

Piggy-Bank
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6816 Accepted: 3272

Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

 

    

测试点数目T

背包为空时重量为E,满载为F

一共有N种物品,给出N种物品的价值V[i]和重量W[i],求出背包装满时最小价值。

解题报告

解题过程一波三折,代码修修补补,状态转移方程修改了两次,终于过了...

第一,我还是没有计算复杂度的习惯;

第二,完全背包思想还没有深刻理解!

首先,这道题是完全背包无疑。需要注意的是要求最小值,也就是求出背包装满的时候。那么在数组赋初值时,我们赋值成正无穷。

第一次,我使用的二维数组保存状态,对应的方程f[i][o]=min{f[i-1][o-k*w[i]]+k*v[i]}(k>=0,(o-k*w[i])>0)。

每次枚举出可能的k,再求出其中最小的,并赋值给f[i][o]。然后,MLE。

第二次,试用一维滚动数组DP,完全套用01背包方程。竟然,TLE。

的确,每一次枚举K的时候,需要Σ(o/w[i]),总的时间复杂度O(N*F*Σ(o/w[i])),太容易超时。

最后,改成f[o]=min{f[o],f[o-w[i]]+v[o]}...终于通过。

这个方程,刚开始还不太理解。

内层循环的含义其实是指,利用k-1个i物品的背包总价值计算出k个的总价值,再与不放物品i比较,取较优解。

这样就避免了上面方法对每个背包容量都穷举一次K造成的重复计算。

如样例2,i=2,o=50时k枚举了0和1。o=100时k=0,1,2;这里的k=0,1的情况可以通过找到f[50]的决策避免计算。

对应更改以后,总算是通过了。

代码

TLE代码:

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <math.h>


using namespace std;
int dp[10020][510];
int v[510],w[510];
void print(int n,int m)
{
    for(int i=0;i<=n;i++)
        {for(int o=0;o<=m;o++)
            printf("%d ",dp[i][o]);
        printf("\n");

        }
}
int main()
{
    int T,N,MAXW,empty;
    scanf("%d",&T);
    for(int t=1;t<=T;t++)
    {
        memset(dp,127,sizeof(dp));
        scanf("%d%d",&empty,&MAXW);
        scanf("%d",&N);
        MAXW-=empty;
        if(MAXW<0)
            {printf("This is impossible.\n");
            continue;
            }


        for(int i=1;i<=N;i++)
            scanf("%d%d",&v[i],&w[i]);


        dp[0][0]=0;
        for(int i=1;i<=N;i++)
            for(int o=0;o<=MAXW;o++)
                {
                    int min=2139062143;
                    for(int k=0;(o-k*w[i])>=0;k++)
                        if((dp[i-1][o-k*w[i]]+k*v[i])<min)
                            min=dp[i-1][o-k*w[i]]+k*v[i];
                    dp[i][o]=min;
                }
      //  print(N,MAXW);
        if(dp[N][MAXW]<2000000000)
        printf("The minimum amount of money in the piggy-bank is %d\n",dp[N][MAXW]);
        else
        printf("This is impossible.\n");
    }
    return 0;

}

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <math.h>

using namespace std;
int dp[50020];
int v[510],w[510];
void print(int n,int m)
{
    printf("**********************\n");
        {for(int o=0;o<=m;o++)
            printf("%d ",dp[o]);
        printf("\n");

        }
    printf("**********************\n");
}


int main()
{

    int T,N,MAXW,empty;
    scanf("%d",&T);
    for(int t=1;t<=T;t++)
    {
        memset(dp,127,sizeof(dp));
        scanf("%d%d",&empty,&MAXW);
        scanf("%d",&N);
        MAXW-=empty;



        for(int i=1;i<=N;i++)
            scanf("%d%d",&v[i],&w[i]);

        if(MAXW<=0)
            {printf("This is impossible.\n");
            continue;
            }
        dp[0]=0;
        for(int i=1;i<=N;i++)
        {
            for(int o=w[i];o<=MAXW;o++)
                {
                        if((dp[o-w[i]]+v[i])<2139062143)
                           dp[o]=min(dp[o-w[i]]+v[i],dp[o]);
                }
            //print(N,MAXW);
            }
       // printf("maxw=%d",MAXW);
        //print(N,MAXW);
        if(dp[MAXW]!=2139062143)
        printf("The minimum amount of money in the piggy-bank is %d.\n",dp[MAXW]);
        else
        printf("This is impossible.\n");
    }   
    return 0;

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值