题目描述
Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5 Ab3bd
Sample Output
2
解题报告
求最小插入元素成为回文序列。
也就是求逆序列的最大公共子序列嘛。。。
代码
#include <iostream>
#include <cstring>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
char s1[6000],s2[6000];
int lsc[2][6000],lenth1,lenth2;
#define max(a,b) (a>b?a:b);
using namespace std;
int main()
{
while(scanf("%d%s",&lenth1,s1)!=EOF)
{
bool zo=false;
int pre,now;
memset(lsc,0,sizeof(lsc));
//lenth1=strlen(s1);
for(int i=0;i<lenth1;i++)
s2[lenth1-1-i]=s1[i];
for(int i=0;i<lenth1;i++){
{pre=zo;zo=not zo;now=zo;}
for(int j=0;j<lenth1;j++){
if(s1[i]==s2[j])
lsc[now][j]=(j!=0?lsc[pre][j-1]+1:1);
else
lsc[now][j]=max(lsc[pre][j],(j!=0?lsc[now][j-1]:0));
}
}
int maximum=-1;
for(int i=0;i<=lenth1;i++)
{maximum=(maximum>lsc[now][i]?maximum:lsc[now][i]);}
printf("%d\n",lenth1-maximum);
}
return 0;
}