Preparing Problem

Memory limit: 262144 kilobytes
input: standard
output: standard



It is not easy to prepare a problem for a programming contest. Petya and Vasya decided that problem "A+B" needs at least  n distinct solutions to be written. It doesn't matter how many solutions each of them will write, they need to write at least  n solutions in total. We know that Petya needs  t 1 units of time to write a solution, and Vasya needs  t 2units of time. They start to work simultaneously at time 0. Thus, for example, Petya finishes writing his first solution at time  t 1, his second solution at 2 ·  t 1 and so on.

Petya and Vasya are working by the same algorithm. Each time Petya (Vasya) finishes writing a solution, he checks on how many solutions have already been written up to the current time moment  t. Ready solutions are the solutions that have been fully written by this time. The solutions that were fully finished exactly at time  t are also considered ready. If the number of such solutions is strictly less than  n, then Petya (Vasya) starts writing the next solution. If a member of the jury began working on a problem, he doesn't stop working under any circumstances, and he will surely finish it.

Petya and Vasya realize that if they act on this algorithm, they will not necessarily write exactly  n solutions in total. Maybe they'll write more solutions.

Considering that Petya and Vasya work non-stop, find, how many solutions they wrote in total and the moment when the latest solution was finished. The latest solution is one which was finished last.

Input
The only input line contains three integers  nt 1 and  t 2 (1 ≤  nt 1t 2 ≤ 5000).

Output
Print two integers —  m and  f, where  m is the number of written solutions, and  f is the moment when the last solution was finished.

Example(s)
sample input
sample output
5 2 3
5 6

sample input
sample output
5 2 4
6 8

sample input
sample output
3 30 50
4 100



Note
In the first sample Petya finished his solutions at time 2, 4 and 6, and Vasya — at time 3 and 6. They finished writing their last solutions simultaneously, at time 6, and at this exact moment they already had the total of 5 written solutions and stopped working.



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;


int main() {
int n, t1, t2;
while(scanf("%d%d%d", &n, &t1, &t2) != EOF) {
int t = 0;
int ta = 0, tb = 0;
while(ta / t1 + ta / t2 < n) {
ta += t1;
}
while(tb / t1 + tb / t2 < n) {
tb += t2;
}
int anst = max(ta, tb);
int ans = ta / t1 + tb / t2;
printf("%d %d\n", ans, anst);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值