hdu 1004 map写法

http://acm.hdu.edu.cn/showproblem.php?pid=1004

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
  
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
  
  
red pink
题目是让统计出现 次数最多的字符串是哪一个。

#include <string>
#include <stdio.h>
#include <iostream>
#include <map>
using namespace std;
int main()
{
    int n;
    string ballon;
    while(cin >> n,n)
    {
        map<string, int> m;
        int N=n;
        while(N--)
        {
            cin >> ballon;
            ++m[ballon];
        }
        map<string,int>::iterator p;
        int maxx=0;
        string max_ballon;
        for(p=m.begin(); p!=m.end(); ++p)
        {
            if(p->second>maxx)
            {
                maxx=p->second;
                max_ballon=p->first;
            }
        }
        cout << max_ballon << endl;
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值