nefu 636

description

There are n classes in Mr Li's grade.And each class have m students.The last examination's ranked results have been finished.Now Mr Li wants to know the score of the student who got the kth place.
							

input

 Each test case have three integers n,m,k(1 <= n <= 10, 1 <= m <= 100,1 <= k <= n*m) in the first line.Then,there are n lines,one line indicating the scores of one class.Each line contains m positive integers.
   Process to the end of file.

output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case.Then,output one integer the score of student who are placed kth,in one line.Print a blank line after each test case, even after the last one.

sample_input

2 4 4
90 87 98 59
78 67 88 99

sample_output

Scenario #1
88
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int cmp(int a,int b)
{
    return a>b;
}
int a[100005];
int main()
{
    int t=1,n,m,k;
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        for(int i=0;i<n*m;i++)
            scanf("%d",&a[i]);
        sort(a,a+(n*m),cmp);
        printf("Scenario #%d\n%d\n",t++,a[k-1]);
    }
    return 0;
}
<br /><span id="_xhe_temp" width="0" height="0"><br /></span>
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值