HRBUST1002 Examination

Examination
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 3739(1175 users)Total Accepted: 1295(1060 users)Rating: Special Judge: No
Description

 There are n classes in Mr Li’s grade.And each class have m student..The last examination’s ranked results have been finished.Now Mr Li wants to know the score of the student who got the kth place.

Input

Each test case have three integers n,m,k(1<=n<=10,1<=m<=100, 1<=k<=n*m) in the first line.Then,there are n lines,one line indicating the scores of one class.Each line contains m positive integers.
Process to the end of file.

Output

For each test case,first print a line saying “Scenario #k”,where k is the number of the test case.Then,output one integer the score of student who are placed kth,in one line.Print a blank line after each test case,even after the last one.

Sample Input
2 4 4
90 87 98 59
78 67 88 99
Sample Output
Scenario #1

88

这个题目解释一下题目意思就好了,一个老师有n个班级,每个班级有m个学生,最好要找出成绩第k高的学生就好了。题目本身没什么难度,喵就直接上sort了(因为懒得写冒泡,直接调用c++标准库的快排函数)。一下是代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<iostream>
using namespace std;

int main(){
    int m,n,k;
    int Case=1;
    while(cin>>n>>m>>k){
        int gra[m*n];
        for(int i=0;i<m*n;i++){
            cin>>gra[i];
        }
        sort(gra,gra+m*n);
        cout<<"Scenario #"<<Case++<<"\n"<<gra[m*n-k]<<"\n\n";
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值