hud 3635 并查集应用

http://acm.hdu.edu.cn/showproblem.php?pid=3635

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 
Input
The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 
Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 
Sample Input
  
  
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
  
  
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
题目大意:

有n个龙珠分布在1~n个地点,进行m次操作,T操作:将x所在地点的所有的球移动到y球所在的地点。Q操作:输出x球所在的地点和该地点存在的球的数目以及x 求总共被移动了几次。

解题思路:刚开始尝试着用枚举暴力的方法做呢,数据太大,时间上根本不允许。后来才知道这是一道并查集的题。每移动一次就相当于吧,以x 为根节点的数连接到以y的根节点为节点的树上,至于移动的次数,就是每移动一次就把对应根节点移动的数目加一,最后递归找x移动的次数即可。

详见代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
const int N=10006;
int root[N],pr[N],sum[N],n;
char s[3];
void build()
{
    for(int i=1;i<=n;i++)
    {
        root[i]=i;
        pr[i]=0;
        sum[i]=1;
    }
}
int find(int r)
{
    while(r!=root[r])
        r=root[r];
    return r;
}
void unio(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x==y)
        return;
    else
    {
        root[x]=root[y];
        pr[x]++;//根节点移动的数目加1
        sum[y]+=sum[x];//y所在节点的龙珠数目加上x的
        sum[x]=0;//x里面为空
    }
}
int main()
{
    int T,m,x,y;
    int tt=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        build();
        printf("Case %d:\n",tt++);//这句话的位置竟然会影响ac我给跪了
        for(int i=0;i<m;i++)
        {
            scanf("%s",s);
            if(s[0]=='T')
            {
                scanf("%d%d",&x,&y);
                unio(x,y);
            }
            else
            {
                scanf("%d",&x);
                int t=find(x);
                int r=x;
                int sum1=pr[x];
                while(r!=root[r])//递归找x移动的次数。
                {
                    r=root[r];
                    sum1+=pr[r];
                }
                printf("%d %d %d\n",t,sum[t],sum1);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值