hdu 1568 大斐波那契数列

http://acm.hdu.edu.cn/showproblem.php?pid=1568



Problem Description
2007年到来了。经过2006年一年的修炼,数学神童zouyu终于把0到100000000的Fibonacci数列
(f[0]=0,f[1]=1;f[i] = f[i-1]+f[i-2](i>=2))的值全部给背了下来。
接下来,CodeStar决定要考考他,于是每问他一个数字,他就要把答案说出来,不过有的数字太长了。所以规定超过4位的只要说出前4位就可以了,可是CodeStar自己又记不住。于是他决定编写一个程序来测验zouyu说的是否正确。
 

Input
输入若干数字n(0 <= n <= 100000000),每个数字一行。读到文件尾。
 

Output
输出f[n]的前4个数字(若不足4个数字,就全部输出)。
 

Sample Input
  
  
0 1 2 3 4 5 35 36 37 38 39 40
 

Sample Output
  
  
0 1 1 2 3 5 9227 1493 2415 3908 6324 1023
详见: http://blog.csdn.net/lvshubao1314/article/details/38013897

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <math.h>
using namespace std;
int a[25];
int main()
{
    a[0]=0;
    a[1]=1;
    for(int i=2;i<22;i++)
        a[i]=a[i-1]+a[i-2];
    //printf("%d\n",a[21]);
    int n;
    while(~scanf("%d",&n))
    {
        if(n<=20)
        {
            printf("%d\n",a[n]);
            continue;
        }
        else
        {
            double log_s=log10(1.0/sqrt(5.0)) +(double)n*log10((1.0+sqrt(5.0))/2.0);
            int ans_s=(int)(pow(10.0,log_s-(int)log_s+3));
            cout <<ans_s<<endl;
        }
    }
    return 0;
}
 
 
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值