HDU5167:Fibonacci(dfs)

Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3215    Accepted Submission(s): 846


Problem Description
Following is the recursive definition of Fibonacci sequence:
Fi=01Fi1+Fi2i = 0i = 1i > 1

Now we need to check whether a number can be expressed as the product of numbers in the Fibonacci sequence.
 

Input
There is a number  T  shows there are  T  test cases below. ( T100,000 )
For each test case , the first line contains a integers n , which means the number need to be checked. 
0n1,000,000,000
 

Output
For each case output "Yes" or "No".
 

Sample Input
  
  
3 4 17 233
 

Sample Output
  
  
Yes No Yes
 

Source
题意:判断一个数能否由斐波拉契数相乘得来。

思路:从大到小dfs斐波拉契数。

# include <iostream>
# include <cstdio>
using namespace std;
int fi[46]={0,1,1};
void init()
{
    for(int i=3; i<45; ++i)
        fi[i] = fi[i-1]+fi[i-2];
}

int dfs(int n, int x)
{
    if(n <= 2) return 1;
    for(int i=x; i>=3; --i)
        if(n%fi[i]==0)
            if(dfs(n/fi[i],i)) return 1;
    return 0;
}
int main()
{
    init();
    int t, n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        if(dfs(n, 44)) puts("Yes");
        else puts("No");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值