hdu1698 线段树 区间更新

http://acm.hdu.edu.cn/showproblem.php?pid=1698

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
题目大意: 

                给定一个初始值均为1的区间1~n,现在对该区间进行Q次操作,每次将区间(x,y)内所有元素的的值全部变为z。求最终所有元素的和。

解题思路:

                    其实这个题最单纯的思路是将区间遍历,从x到y,这样一来复杂度就是O(N*Q)肯定会超时的。怎么办呢?我们可以用线段树来存储这一段区间,线段树成段更新问题。。成段更新与单点更新就不同了。成段更新没必要更新到单个点,当找到要更新的区间时直接更新这一整个区间返回即可,若上面没有返回,就要传递属性,即把该区间的价值属性传递给左右儿子,并且把该区间的价值属性设为-1,标志它已把价值传递给左右子树了。这是比较重要的一点。当计算总区间的和时,区间的价值是很重要的一点,若它的价值是正值(1,2,3,),直接计算该区间之和返回即可,但若是-1,说明更新时它已把价值传递给左右子树,这时要递归左右子树求区间之和。

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
typedef long long LL;
const int N=100005;
int n;
struct SegmentTree
{
    struct Tree
    {
       int l,r;//左右区间边界
       LL sum;//区间和
       int  flag;//标记
    }tree[N*3];
    void push_up(int root)//向上维护
    {
        tree[root].sum=tree[root<<1].sum+tree[root<<1|1].sum;
    }
    void push_down(int root)//向下维护
    {
        if(tree[root].flag!=-1)
        {
            tree[root<<1].flag=tree[root<<1|1].flag=tree[root].flag;//左右子树做标记
            tree[root<<1].sum=(tree[root<<1].r-tree[root<<1].l+1)*tree[root].flag;
            tree[root<<1|1].sum=(tree[root<<1|1].r-tree[root<<1|1].l+1)*tree[root].flag;
            tree[root].flag=-1;//该节点的子树已经更新完毕,其取消标记
        }
    }
    void build(int root,int L,int R)//构建线段树 1~n
    {
        tree[root].l=L;
        tree[root].r=R;
        tree[root].flag=-1;//初始为未标记状态
        tree[root].sum=1;
        if(tree[root].l==tree[root].r)
            return;
        int mid=L+(R-L)/2;
        build(root<<1,L,mid);
        build(root<<1|1,mid+1,R);
        push_up(root);
    }
    void update(int root,int L,int R,int k)
    {
        if(L<=tree[root].l&&tree[root].r<=R)
        {
            tree[root].flag=k;
            tree[root].sum=(tree[root].r-tree[root].l+1)*tree[root].flag;
            return;
        }
        push_down(root);//返回语句没有执行,把其属性传给左右儿子节点
        int mid=tree[root].l+(tree[root].r-tree[root].l)/2;
        if(L<=mid) update(root<<1,L,R,k);
        if(R>mid)  update(root<<1|1,L,R,k);
        push_up(root);
    }
}tr;
int main()
{
    int T,n,m;
    int tt=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        {
            tr.build(1,1,n);
            for(int i=0;i<m;i++)
            {
                int r,l,x;
                scanf("%d%d%d",&l,&r,&x);
                tr.update(1,l,r,x);
            }
            printf("Case %d: The total value of the hook is %I64d.\n",++tt,tr.tree[1].sum);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值