HDU3530 单调队列的应用

http://acm.hdu.edu.cn/showproblem.php?pid=3530

Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
 

Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.
 

Output
For each test case, print the length of the subsequence on a single line.
 

Sample Input
  
  
5 0 0 1 1 1 1 1 5 0 3 1 2 3 4 5
 

Sample Output
  
  
5 4
/**
HDU 3530  单调队列的应用
题意:
     给定一段序列,求出最长的一段子序列使得该子序列中最大最小只差x满足m<=x<=k。
解题思路:
     建立两个单调队列分别递增和递减维护(头尾删除,只有尾可插入)
     Max - Min 为两个队列的队首之差while(Max-Min>K) 看哪个的队首元素比较前就移动谁的
     最后求长度时,需要先记录上一次的被淘汰的最值位置last ,这样[last+1,i]即为满足条件的连续子序列了
i - last
*/
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
const int N=100005;
int q_max[N],q_min[N];//递增,递减
int a[N],n,m,k;
int main()
{
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        int head_min=0,head_max=0,tail_min=0,tail_max=0;
        int left1=0,left2=0;
        int maxx=0;
        for(int i=1;i<=n;i++)
        {
            while(head_min<tail_min&&a[q_min[tail_min-1]]<=a[i])
                tail_min--;
            while(head_max<tail_max&&a[q_max[tail_max-1]]>=a[i])
                tail_max--;
            q_max[tail_max++]=q_min[tail_min++]=i;
           /* printf("***%d 递减、递增***\n",i);
            for(int j=head_min;j<tail_min;j++)
                   printf("%d ",a[q_min[j]]);
            printf("\n");
            for(int j=head_max;j<tail_max;j++)
                   printf("%d ",a[q_max[j]]);
            printf("\n");*/
            while(a[q_min[head_min]]-a[q_max[head_max]]>k)
            {
                if(q_min[head_min]<q_max[head_max])
                      left1=q_min[head_min++];
                else
                      left2=q_max[head_max++];
            }
            if(a[q_min[head_min]]-a[q_max[head_max]]>=m)
                  maxx=max(maxx,i-max(left1,left2));
        }
        printf("%d\n",maxx);
    }
    return 0;
}
/*
5 2 3
1 -1 2 -6 5
5 1 3
1 2 3 4 5
6 0 0
-1 0 2 1 125 -5
*/


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值