UVALIve 4256 图的dp

https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=2257

Traveling salesmen of nhn. (the prestigious Korean internet company) report their current location to the company on a regular basis. They also have to report their new location to the company if they are moving to another location. The company keep each salesman's working path on a map of his working area and uses this path information for the planning of the next work of the salesman. The map of a salesman's working area is represented as a connected and undirected graph, where vertices represent the possible locations of the salesman an edges correspond to the possible movements between locations. Therefore the salesman's working path can be denoted by a sequence of vertices in the graph. Since each salesman reports his position regularly an he can stay at some place for a very long time, the same vertices of the graph can appear consecutively in his working path. Let a salesman's working path be correct if two consecutive vertices correspond either the same vertex or two adjacent vertices in the graph.

For example on the following graph representing the working area of a salesman,

\epsfbox{p4256.eps}

a reported working path [1 2 2 6 5 5 5 7 4] is a correct path. But a reported working path [1 2 2 7 5 5 5 7 4] is not a correct path since there is no edge in the graph between vertices 2 a 7. If we assume that the salesman reports his location every time when he has to report his location (but possibly incorrectly), then the correct path could be [1 2 2 4 5 5 5 7 4], [1 2 4 7 5 5 5 7 4], or [1 2 2 6 5 5 5 7 4].

The length of a working path is the number of vertices in the path. We define the distance between two pathsA = a1a2...an and B = b1b2...bn of the same length n as

dist( AB) =  $\displaystyle \sum^{​{n}}_{​{i=1}}$ d ( a ib i)

where

d ( ab) =  $\displaystyle \left\{\vphantom{ \begin{array}{cc} 0 & \mbox{if } a=b \\  1 & \mbox{otherwise} \end{array} }\right.$ $\displaystyle \begin{array}{cc} 0 & \mbox{if } a=b \\  1 & \mbox{otherwise} \end{array}$

Given a graph representing the working area of a salesman and a working path (possible not a correct path), A, of a salesman, write a program to compute a correct working path, B , of the same length where the distancedist(AB) is minimized.

Input 

The program is to read the input from standard input. The input consists of T test cases. The number of test cases (T) is given in the first line of the input. The first line of each test case contains two integers n1n2 (3$ \le$n1$ \le$100, 2$ \le$n2$ \le$4, 950) where n1 is the number of vertices of the graph representing the working map of a salesman and n2 is the number of edges in the graph. The input graph is a connected graph. Each vertex of the graph is numbered from 1 to n1 . In the following n2 lines, each line contains a pair of vertices which represent an edge of the graph. The last line of each test case contains information on a working path of the salesman. The first integer n (2$ \le$n$ \le$200) in the line is the length of the path and the following n integers represent the sequence of vertices in the working path.

Output 

Your program is to write to standard output. Print one line for each test case. The line should contain the minimum distance of the input path to a correct path of the same length.

Sample Input 

2 
7 9 
1 2 
2 3 
2 4 
2 6 
3 4 
4 5 
5 6 
7 4 
7 5 
9 1 2 2 7 5 5 5 7 4 
7 9 
1 2 
2 3 
2 4 
2 6 
3 4 
4 5 
5 6 
7 4 
7 5 
9 1 2 2 6 5 5 5 7 4

Sample Output 

1 
0
题目大意:

        给定一个包含n个点的无向连通图和一个长为L的序列,你的任务是修改尽量少的点,使得序列中的任意两个相邻的数或者相同,或者相邻
大体思路:

      不算太难想到的DP。dp[i][j]表示第i个是j ,前i个数的最少的修改数,然后每次都枚举它的相邻点,所以dp[i][j]=min(dp[i][j],dp[i-1][k])

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <vector>
using namespace std;
vector<int> p[1005];
int a[5005],dp[1005][105];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int  n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            p[i].clear();
            p[i].push_back(i);
        }
        for(int i=0;i<m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            p[x].push_back(y);
            p[y].push_back(x);
        }
        int num;
        scanf("%d",&num);
        for(int i=1;i<=num;i++)
            scanf("%d",&a[i]);
        memset(dp,0x3f3f3f3f,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            if(i==a[1])
                dp[1][i]=0;
            else
                dp[1][i]=1;
        }
        for(int i=2;i<=num;i++)
            for(int j=1;j<=n;j++)
            {
                int len=p[j].size();
                for(int k=0;k<len;k++)
                {
                    int temp=p[j][k];
                    dp[i][j]=min(dp[i][j],dp[i-1][temp]);
                }
                if(j!=a[i])
                    dp[i][j]++;
            }
        int minn=0x3f3f3f3f;
        for(int i=1;i<=n;i++)
            minn=min(minn,dp[num][i]);
        printf("%d\n",minn);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值