2014西安网络赛1008||hdu5014 二进制

http://acm.hdu.edu.cn/showproblem.php?pid=5014

Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
  
  
4 2 0 1 4 3
 

Sample Output
  
  
20 1 0 2 3 4
 

解题思路:我们知道一个数有n个二进制位,我们就把它异或成(1<< n)-1,就最大了,因此我们给每一个数从大到小用(1<< n)-1做异或就能得到与之对应的数,注意一定不能从小到大做。

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

typedef __int64 LL;
const int N=100055;

int a[N],b[N],vis[N];
int n;

int get(int x)
{
    int num=0;
    while(x)
    {
        x>>=1;
        num++;
    }
    return num;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<=n;i++)
            scanf("%d",&a[i]);
        memset(vis,-1,sizeof(vis));
        for(int i=n;i>=0;i--)
        {
            if(vis[i]!=-1)
                continue;
            int x=get(i);
            int tmp=((1<<x)-1)^i;
            b[i]=tmp;
            b[tmp]=i;
            //printf("%d\n",b[i]);
            vis[tmp]=1;
            vis[i]=1;
        }
        LL sum=0;
        for(int i=0;i<=n;i++)
            sum+=(LL)(i^b[i]);
        printf("%I64d\n",sum);
        for(int i=0;i<=n;i++)
            printf(i!=n?"%d ":"%d\n",b[a[i]]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值