poj 2411 状态压缩dp

http://poj.org/problem?id=2411

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205
题目大意:用1*2的砖,铺满n*m的表格,问有多少方案

/**
状态压缩dp 思路都是用0和1表示,用11表示横放 上一行0 下一行1表示竖放,
因为这一行的状态只和上一行有关。这样表示最后一行一定都是1,结果就是dp[n][(1<<m)-1],
用dfs搜一遍所有情况,s1是上一行 s2表示下一行 用vector存一下。
特判一下第一行,因为是第一行所以可以有任意个0,但相邻1的个数一定是偶数。
所有准备工作都完成之后进行状态转移
*/
#include <iostream>
#include <vector>
#include <cstring>
#include <cstdio>
using namespace std;
const int N=1<<11;
long long int dp[2][N];
vector<int> vec[N];

void dfs(int cnt,int s1,int s2,int n)
{
    if(n==cnt)
    {
        vec[s2].push_back(s1);
        return;
    }
    dfs(cnt+1,s1<<1,s2<<1|1,n);
    dfs(cnt+1,s1<<1|1,s2<<1,n);
    if(cnt<n-1)
        dfs(cnt+2,s1<<2|3,s2<<2|3,n);
}

int pdf(int a)
{
    while(a>0)
    {
        if((a&3)==3)a>>=2;
        else if(a%2==0)a>>=1;
        else return 0;
    }
    return 1;
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0)
            break;
        memset(dp[0],0,sizeof(dp[0]));
        memset(vec,0,sizeof(vec));
        dfs(0,0,0,m);
        for(int i=0; i<1<<m; i++)
            if(pdf(i))dp[0][i]=1;
        int cnt=0;
        for(int i=1; i<n; i++)
        {
            cnt^=1;
            memset(dp[cnt],0,sizeof(dp[cnt]));
            for(int j=0; j<1<<m; j++)
                for(int k=0; k<vec[j].size(); k++)
                    dp[cnt][j]+=dp[cnt^1][vec[j][k]];
        }
        printf("%lld\n",dp[cnt][(1<<m)-1]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值