poj1141 区间dp

17 篇文章 0 订阅

http://poj.org/problem?id=1141

Description

Let us define a regular brackets sequence in the following way: 

1. Empty sequence is a regular sequence. 
2. If S is a regular sequence, then (S) and [S] are both regular sequences. 
3. If A and B are regular sequences, then AB is a regular sequence. 

For example, all of the following sequences of characters are regular brackets sequences: 

(), [], (()), ([]), ()[], ()[()] 

And all of the following character sequences are not: 

(, [, ), )(, ([)], ([(] 

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]
/**
 poj1141区间dp
 给定一定长度的括号,求至少添加几个能是给定的括号匹配。
 dp[i][j] 表示区间i~j之间至少要添加多少括号,从区间的长度由小变大依次遍历,a[i]==a[j],dp[i][j]=dp[i+1][j-1]
 状态转移方程dp[i][j]=max(dp[i][k],dp[k][j]),k:i~j-1;每次更新都记录下更新的位置mark[i][j]=k, 最后递归输出即可。

*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

int dp[120][120];
int mark[120][120];
char a[120];
void print(int x,int y)
{
    if(x>y)
        return;
    if(x==y)
    {
        if(a[x]=='('||a[x]==')')
            printf("()");
        else
            printf("[]");
    }
    else if(mark[x][y]==-1)
    {
        printf("%c",a[x]);
        print(x+1,y-1);
        printf("%c",a[y]);
    }
    else
    {
        print(x,mark[x][y]);
        print(mark[x][y]+1,y);
    }
}
int main()
{
    scanf("%s",a);
    int n=strlen(a);
    memset(dp,0,sizeof(dp));
    for(int i=0; i<n; i++)
        dp[i][i]=1;
    for(int l=1; l<n; l++)
    {
        for(int i=0; i<n-l; i++)
        {
            int j=i+l;
            dp[i][j]=111111111;
            if((a[i]=='('&&a[j]==')')||(a[i]=='['&&a[j]==']'))
            {
                dp[i][j]=dp[i+1][j-1];
                mark[i][j]=-1;
            }
            for(int k=i; k<j; k++)
            {
                if(dp[i][j]>dp[i][k]+dp[k+1][j])
                {
                    dp[i][j]=dp[i][k]+dp[k+1][j];
                    mark[i][j]=k;
                }
            }
        }
    }
    print(0,n-1);
    puts("");
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值