HDU 3530(单调队列)

There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.

Input

There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.

Output

For each test case, print the length of the subsequence on a single line.

Sample Input

5 0 0
1 1 1 1 1
5 0 3
1 2 3 4 5

Sample Output

5
4

题目意思很简单,就是让你求最长的一个子序列,这个子序列满足这个序列的最大值减去最小值大于等于m小于等于k,然后输出满足条件的最长子序列的长度
思路:因为你求最长长度,得用到最大值和最小值,所以你得求单调递增序列和单调递减序列,这样才能进行相减什么的,其他的话正常操作

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#define MAX 100002
#include<deque>
#include<math.h>
using namespace std;
int s[100005],v[100005],q1[100005],q2[100005];
int main()
{
    int n,m,k;
    while(scanf("%d%d%d",&n,&m,&k)!=EOF)
    {
        int head1=1,tail1=0,head2=1,tail2=0,ans=0,now=1;
        for(int a=1;a<=n;a++)
        {
            scanf("%d",&v[a]);
            while(head1<=tail1&&v[a]>v[q1[tail1]])//维护单调递减队列
                tail1--;
            while(head2<=tail2&&v[a]<v[q2[tail2]]) //维护单调递增队列
                tail2--;
            q1[++tail1]=a;
            q2[++tail2]=a;
            while(head1<=tail1&&head2<=tail2&&(v[q1[head1]]-v[q2[head2]])>k)
            {
                if(q1[head1]<q2[head2])
                {
                    now=q1[head1++]+1; 
                }
                else
                {
                    now=q2[head2++]+1;
                }
            }
            if(head1<=tail1&&head2<=tail2&&(v[q1[head1]]-v[q2[head2]])>=m)
            {
                ans=max(ans,a-now+1);
            }
//            printf("%d ",ans);
        }
        printf("%d\n",ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值