poj2392 多重背包问题

20 篇文章 0 订阅

http://poj.org/problem?id=2392

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.



/**
poj2392  多重背包问题
题目大意:有n种石头,每种石头的高度为h,数量为c,可以存在的最高的高度为a,求怎样安排使得所有的石头在满足要求的前提下可以叠加到最高的高度
解题思路;将所有的石头按照高度上限来进行排序,再按多重背包来做。至于为什么排序,是因为如果限制高的先拍,后面限制低的石头就可能无法使用了。
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

struct note
{
    int h,a,c;
}p[410];

bool cmp(note x,note y)
{
    return x.a<y.a;
}
int n,dp[40010];
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&p[i].h,&p[i].a,&p[i].c);
        }
        dp[0]=1;
        sort(p,p+n,cmp);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<p[i].c;j++)
            {
                for(int k=p[i].a;k>=p[i].h;k--)
                {
                    dp[k]|=dp[k-p[i].h];
                }
            }
        }
        int cnt=0;
        for(int i=p[n-1].a;i>=0;i--)
        {
            if(dp[i])
            {
                cnt=i;
                break;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}
2392Accepted452K79MSC++1255B2014-11-16 20:37:52

/**
poj2392  多重背包问题
写法二,速度更快
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

struct note
{
    int h,a,c;
} p[410];

bool cmp(note x,note y)
{
    return x.a<y.a;
}
int n,dp[40010],times[40010];
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d%d%d",&p[i].h,&p[i].a,&p[i].c);
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        sort(p,p+n,cmp);
        for(int i=0; i<n; i++)
        {
            memset(times,0,sizeof(times));
            for(int k=p[i].h; k<=p[i].a; k++)
            {
                if(!dp[k]&&dp[k-p[i].h]&×[k-p[i].h]+1<=p[i].c)
                {
                      times[k]=times[k-p[i].h]+1;
                      dp[k]|=dp[k-p[i].h];
                }
            }
        }
        int cnt=0;
        for(int i=p[n-1].a; i>=0; i--)
        {
            if(dp[i])
            {
                cnt=i;
                break;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值