POJ 2392 多重背包

 

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

题意:有n种石头,每个石头的高度hi,允许用的最高高度为ai,数量为ci,求能组合的最高高度。

 

思路:先给这些石头排个序,最高高度小的在前面,这样才能使得高度最大,然后再按多重背包来做,这样就可以了。

 

#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct node{
    int ci,hi,ai;
    bool operator < (const node &a)const
    {
        return ai<a.ai;
    }
}num[500];
bool cmp(node a,node b)
{
    return a.ai<b.ai;
}
int f[40010];
int dp[40010];
int main() {
	int n;
//	memset(dp,-1,sizeof dp);
	scanf("%d",&n);
	for(int i=0;i<n;i++)
        scanf("%d%d%d",&num[i].hi,&num[i].ai,&num[i].ci);
        sort(num,num+n);
        dp[0]=1;
    for(int i=0;i<n;i++)
    {
        for(int j=1;j<=num[i].ci;j++)
        {
            for(int k=num[i].ai;k>=num[i].hi;k--)
                dp[k]|=dp[k-num[i].hi];
        }
    }

    for(int i=40000;i>=0;i--)
    if(dp[i]==1){
        printf("%d\n",i);break;
    }
	return 0;
}

上面的方法类似01背包来解决 ,但两种方法都是将ai从小到大排好序,然后枚举数量来找到最优解

#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct node{
    int ci,hi,ai;
    bool operator < (const node &a)const
    {
        return ai<a.ai;
    }
}num[500];
bool cmp(node a,node b)
{
    return a.ai<b.ai;
}
int f[40010];
int dp[40010];
int main() {
	int n;
	memset(dp,-1,sizeof dp);
	scanf("%d",&n);
	for(int i=0;i<n;i++)
        scanf("%d%d%d",&num[i].hi,&num[i].ai,&num[i].ci);
        sort(num,num+n);
        dp[0]=0;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<=num[i].ai;j++)
        {
            if(dp[j]>=0)
                dp[j]=num[i].ci;
            else{
                int t=j-num[i].hi;
                if(t>=0&&dp[t]>0)
                    dp[j]=dp[t]-1;
            }
        }
    }

    for(int i=40000;i>=0;i--)
    if(dp[i]>=0){
        printf("%d\n",i);break;
    }
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值