http://acm.hdu.edu.cn/showproblem.php?pid=4586
Problem Description
There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.
Input
Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
Output
Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.
Sample Input
6 1 2 3 4 5 6 0 4 0 0 0 0 1 3
Sample Output
3.50 0.00
/**
hdu 4586 概率dp
题目大意:给定一个骰子,有n个面,掷得i面朝上获得a[i]的money,其中有m个面掷得其中之一朝上除了获得money外,并获得再掷一次的机会
问掷一个回合获得money的期望
解题思路:(kuangbin)
设所求期望为ans
那么ans=1/N *(A[B[1]]+ans) + 1/N *(A[B[2]]+ans) + ...1/N *(A[B[M]]+ans) + 1/N A[k]+....
ans=M/N *ans+1/N*(A[1]+A[2]+A[3]+....+A[N]);
(N-M)ans= A[1]+A[2]+...+A[N]=sum;
如果sum==0,答案为0.00
如果sum!=0,N-M==0 答案为inf
否则答案就是sum/(N-M);
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int n,m;
int a[1005],b[1005];
int main()
{
while(~scanf("%d",&n))
{
double sum=0;
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
sum+=a[i];
}
scanf("%d",&m);
for(int i=0;i<m;i++)
{
scanf("%d",&b[i]);
}
if(sum==0.0)printf("0.00\n");
else if(n==m)printf("inf\n");
else printf("%.2lf\n",sum/(n-m));
}
return 0;
}
Problem Description
There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.
Input
Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
Output
Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.
Sample Input
6 1 2 3 4 5 6 0 4 0 0 0 0 1 3
Sample Output
3.50 0.00