HDU 4586

Play the Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1328    Accepted Submission(s): 429
Special Judge


Problem Description
There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.
 

Input
Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
 

Output
Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.
 

Sample Input
  
  
6 1 2 3 4 5 6 0 4 0 0 0 0 1 3
 

Sample Output
  
  
3.50

0.00

题意:有一个有n个面的骰子,每个面上有一个权值,投掷一次,上面的面值是多少,就能拿到多少钱,其中有些面有一些特殊颜色,摇到这些面的时候可以再投掷一次,问最终能拿到的钱的期望值。

思路:一次投掷能拿sum/n;如果投掷到有颜色的m个面中的任意一个,会额外得到sum*m/n/n,以此类推,最终的期望就是sum/n*((n/m)^0+(n/m)^1+(n/m)^2+……)。等比数列求和公式,算出来是(1-(n/m)^∞)/(1-(n/m));当n == m时,(n/m)^∞ == 1,所以原式结果是0,当n !=m时,(n/m)^∞ 趋近于 0,则原式变为sum/n*/(1 - (n/m))也就是sum/(n-m)。

一开始写的递推公式,怎么都不过,后来发现无论是什么样例,结果都是sum/(n-m),交了一发竟然对了,后来才明白是这么回事。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<vector>
#include<set>
using namespace std;
double ans,pre;
int n;
int main()
{
    int m;
    while(scanf("%d",&n)!=EOF)
    {
        ans = 0.00;
        for(int i = 0;i < n;i++)
        {
            int num;
            scanf("%d",&num);
            ans+=num;
        }
        scanf("%d",&m);
        for(int i = 0;i < m;i++)
        {
            int num;
            scanf("%d",&num);
        }
        if(ans == 0)
        {
            printf("0.00\n");
            continue;
        }
        if(m == n)
            printf("inf\n");
        else
            printf("%.2lf\n",ans/(n-m));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值