hdu3829 二分图的最大独立集

http://acm.hdu.edu.cn/showproblem.php?pid=3829

Cat VS Dog

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 2851    Accepted Submission(s): 972


Problem Description
The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.
 

Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)
 

Output
For each case, output a single integer: the maximum number of happy children.
 

Sample Input
  
  
1 1 2 C1 D1 D1 C1 1 2 4 C1 D1 C1 D1 C1 D2 D2 C1
 

Sample Output
  
  
1 3
Hint
Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.
/**
hdu 3829 二分图的最大独立集
题目大意:有k个小孩,n只狗,m只猫,每个小孩喜欢一个宠物,讨厌一个宠物,若我们拿走一个小孩讨厌的宠物,而剩下的
          有该小孩喜欢的宠物,那么这个小孩就会高兴。问怎么样拿可以使最多的小孩高兴。
解题思路:二分图的最大独立集问题,对于两个不能同时高兴的小孩建边,最后最大独立集=k-最大匹配数。难在建边
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=505;

int k,n,m;
int w[maxn][maxn];
bool used[maxn];
int linker[maxn];

bool dfs(int u)
{
    int v;
    for(v=0;v<k;v++)
    {
        if(w[u][v]&&!used[v])
        {
            used[v]=true;
            if(linker[v]==-1||dfs(linker[v]))
            {
                linker[v]=u;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int res=0;
    int u;
    memset(linker,-1,sizeof(linker));
    for(u=0;u<k;u++)
    {
        memset(used,0,sizeof(used));
        if(dfs(u))res++;
    }
    return res;
}

char like[maxn][5],dislike[maxn][5];

int main()
{
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        for(int i=0;i<k;i++)
        {
            scanf("%s%s",like[i],dislike[i]);
        }
        memset(w,0,sizeof(w));
        for(int i=0;i<k;i++)
        {
            for(int j=0;j<k;j++)
            {
                if(strcmp(like[i],dislike[j])==0||strcmp(dislike[i],like[j])==0)
                {
                    w[i][j]=1;
                }
            }
        }
        printf("%d\n",k-hungary()/2);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值