HDU1495 BFS

Problem Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
 

Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
 

Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
 

Sample Input
  
  
7 4 3 4 1 3 0 0 0
 

Sample Output
  
  
NO 3
 

直接暴力BFS,枚举从一个水杯到其它两个水杯的情况


#include <cstdio>
#include <cstring>
#include<map>
#include <queue>
#include <iostream>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
#define eps 1e-10
#define ll long long
#include<cmath>
using namespace std;
int vis[105][105][105];
int n,x,y;

struct node
{
    int s,a,b;
    int mov;
};
queue<node > q;
int bfs(node start)
{
    while(!q.empty())   q.pop();
    q.push(start);
    while(!q.empty())
    {
        node tmp = q.front();
        q.pop();
        node next;
        if(tmp.s!=0)   ///s -> a
        {
            if(tmp.s<=x-tmp.a)
            {
                next.s = 0;
                next.a  =tmp.a + tmp.s;
                next.b = tmp.b;
            }
            else
            {
                next.s   =tmp.s - (x-tmp.a);
                next.a = x;
                next.b = tmp.b;
            }
            next.mov = tmp.mov+ 1;
            if(next.s == n/2)
                return  next.mov;
            if(! vis[next.s][next.a][next.b])
            {
                q.push(next);
                vis[next.s][next.a][next.b] = 1;
            }

            if(tmp.s<=y-tmp.b)///s -> b
            {
                next.s = 0;
                next.a  =tmp.a;
                next.b = tmp.b + tmp.s;
            }
            else
            {
                next.s   =tmp.s -(y-tmp.b);
                next.a = tmp.a;
                next.b = y;
            }
            next.mov = tmp.mov+ 1;
            if(next.s == n/2)
                return  next.mov;
            if(! vis[next.s][next.a][next.b])
            {
                q.push(next);
                vis[next.s][next.a][next.b] = 1;
            }
        }
        if(tmp.a!=0)
        {
            if(tmp.a<=y-tmp.b)  ///a -> b
            {
                next.a = 0;
                next.b = tmp.b+tmp.a;
            }
            else
            {
                next.a  = tmp.a -(y-tmp.b);
                next.b = y;
            }
            next.s  = tmp.s;
            next.mov = tmp.mov + 1;
            if(next.s==n/2)
                return  next.mov;
            if(!vis[next.s][next.a][next.b])
            {
                q.push(next);
                vis[next.s][next.a][next.b] = 1;
            }
            next.s = tmp.s+tmp.a;
            next.a = 0;
            next.b = tmp.b;
            next.mov = tmp.mov + 1;
            if(next.s==n/2)
                return next.mov;
            if(!vis[next.s][next.a][next.b])
            {
                q.push(next);
                vis[next.s][next.a][next.b] = 1;
            }
        }
        if(tmp.b != 0)   /// b -> a
        {
            if(tmp.b<=x-tmp.a)
            {
                next.a = tmp.a+tmp.b;
                next.b = 0;
            }
            else
            {
                next.a= x;
                next.b=tmp.b-(x-tmp.a);
            }
            next.s = tmp.s;
            next.mov = tmp.mov + 1;
             if(!vis[next.s][next.a][next.b])
            {
                q.push(next);
                vis[next.s][next.a][next.b] = 1;
            }

            next.s = tmp.s + tmp.b;
            next.b  = 0;
            next.a  = tmp.a;
            next.mov = tmp.mov+ 1;
            if(next.s==n/2)
                return next.mov;
            if(!vis[next.s][next.a][next.b])
            {
                q.push(next);
                vis[next.s][next.a][next.b] = 1;
            }
        }
    }
    return -1;
}
int main()
{
    while(scanf("%d%d%d",&n,&x,&y)!=EOF)
    {
        if(n+x+y==0)
            break;
        if(n%2!=0)
        {
            printf("NO\n");
            continue;
        }
        memset(vis,0,sizeof(vis));
        node tmp;
        tmp.s = n;
        tmp.a = 0;
        tmp.b = 0;
        tmp.mov = 0;
        vis[n][x][y] = 1;
        int ans  = bfs(tmp);
        if(ans==-1)
             printf("NO\n");
        else
          printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值