Biorhythms

Description 
Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.  
Input 
You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1. 
Output 
For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:  
Case 1: the next triple peak occurs in 1234 days.  
Use the plural form ``days'' even if the answer is 1. 
Sample Input
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

题目翻译: 
Description 
人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表现出色。例如,智力周期的高峰,人会思维敏捷,精力容易高度集中。因为三个周期的周长不同,所以通常三个周期的高峰不会落在同一天。对于每个人,我们想知道何时三个高峰落在同一天。对于每个周期,我们会给出从当前年份的第一天开始,到出现高峰的天数(不一定是第一次高峰出现的时间)。你的任务是给定一个从当年第一天开始数的天数,输出从给定时间开始(不包括给定时间)下一次三个高峰落在同一天的时间(距给定时间的天数)。例如:给定时间为10,下次出现三个高峰同天的时间是12,则输出2(注意这里不是3)。 
Input 
输入四个整数:p, e, i和d。 p, e, i分别表示体力、情感和智力高峰出现的时间(时间从当年的第一天开始计算)。d 是给定的时间,可能小于p, e, 或 i。 所有给定时间是非负的并且小于365, 所求的时间小于21252。  
当p = e = i = d = -1时,输入数据结束。 
Output 
从给定时间起,下一次三个高峰同天的时间(距离给定时间的天数)。  
采用以下格式: 
Case 1: the next triple peak occurs in 1234 days.  
注意:即使结果是1天,也使用复数形式“days”。 
中国剩余定理(CRT,Chinese Reminder Theory,又称孙子定理)  


介绍:  
《孙子算经》中的题目:有物不知其数,三个一数余二,五个一数余三,七个一数又余二,问该物总数几何?  
《孙子算经》中的解法:三三数之,取数七十,与余数二相乘;五五数之,取数二十一,与余数三相乘;七七数之,取数十五,与余数二相乘。将诸乘积相加,然后减去一百零五的倍数。  
解析:  
我们假设n1是满足除以3余2的一个数,n2是满足除以5余3的一个数,n3是满足除以7余2的一个数。


如果n2是3的倍数,n1+n2就依然满足除以3余2。同理,如果n3也是3的倍数,那么n1+n2+n3的和就满足除以3余2。这是从n1的角度考虑的,再从n2,n3的角度出发,我们可推导出以下三点:
  1. 为使n1+n2+n3的和满足除以3余2,n2和n3必须是3的倍数。
  2. 为使n1+n2+n3的和满足除以5余3,n1和n3必须是5的倍数。
  3. 为使n1+n2+n3的和满足除以7余2,n1和n2必须是7的倍数。

综合上述三点,为使n1+n2+n3的和作为“孙子问题”的一个最终解,需满足:
  1. n1除以3余2,且是5和7的公倍数——35。
  2. n2除以5余3,且是3和7的公倍数——63。
  3. n3除以7余2,且是3和5的公倍数——30。

所以n1+n2+n3=(35+63+30)%105=23  


但我们不这样想,注意到《孙子算经》的解法中的三个关键数70,21,15。它们有何妙用,有何性质呢?  
首先,70是3除余1而5与7都除得尽的数,所以70a是3除余a,而5与7都除得尽的数。  
同理,21b是5除余b,而3与7除得尽的数;15c是7除余c,3与5除得尽的数。  
总加起来 70a+21b+15c 是3除余a,5除余b ,7除余c的数,也就是可能答案之一(但可能不是最小的),这数加减105(105=3×5×7)仍有这样性质,可以多次减去105而得到最小的正数解。(这里取a=2,b=3,c=2)  
把上述思想用到这一题中,  
就有:  
使33×28×a被23除余1,用33×28×8=5544; 
使23×33×b被28除余1,用23×33×19=14421; 
使23×28×c被33除余1,用23×28×2=1288。
 


那么上面的8,19,2怎么来的呢?  
比如8,我们有 33×28×a-23m=1,这就转化 成了线性不定方程ax+by=c, 其解法请参考 这篇文章  


因此有(5544×p+14421×e+1288×i)% lcm(23,28,33) =n+d   
又23、28、33互质,即lcm(23,28,33)= 21252;
所以有n=(5544×p+14421×e+1288×i-d)%21252
 
本题所求的是最小整数解,避免n为负,因此最后结果为n=(n+21252)%21252
那么最终求解n的表达式就是:
 
n=(5544*p+14421*e+1288*i-d+21252)%21252  
(若n为0,就令n为21252)  
完整代码:  
/*16ms,248KB*/

#include<cstdio>
using namespace std;

int main(void)
{
	int p, e, i, d, icase = 1;
	while (scanf("%d%d%d%d", &p, &e, &i, &d), ~p)
	{
		int n = (5544 * p + 14421 * e + 1288 * i - d + 21252) % 21252;
		if (n == 0)
			n = 21252;
        printf("Case %d: the next triple peak occurs in %d days.\n",icase++,n);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值