hdu Elevator

Elevator

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 48   Accepted Submission(s) : 29
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

Author

ZHENG, Jianqiang

Source

ZJCPC2004
题目大意:输入有多组数据,每组数据为一行,输入0时结束。对于每组数据计算电梯在给出的数据所示的路径走过所需的时间。电梯往上走一层楼需6秒往下走一层需4秒,每次到所需楼层时停顿5秒。
#include<iostream>
using namespace std;
int main()
{
    int n,m,i,s,sum;
    while((cin>>n)&&n!=0)
    {
        sum=0;
        s=0;               //电梯从0层开始
        for(i=0;i<n;i++)
        {
            cin>>m;
            if(m-s>0)           //如果是上楼加6乘上的楼梯数
            sum=sum+(m-s)*6;
            else                //如果下楼加4乘下的楼梯数
            sum=sum+(s-m)*4;
            s=m;                //每停一次把下一次开始的楼层赋给s
        }
        sum=sum+n*5;         //再加上电梯在每一种情况下停的次数乘5
        cout<<sum<<endl;      //输出共花的时间
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值