ACM HDU Elevator 电梯



The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

 

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

 

Output

Print the total time on a single line for each test case.

 

Sample Input

1 2 3 2 3 1 0

 

Sample Output

17 41

 题目大意:题目描述的是电梯每上一层楼需要六秒钟的时间,并且在其到达的楼层停顿五秒,电梯每下一层楼需要花费四秒钟的时间;​

个人感想:此题纯属一道加法题;​

问题:1.电梯到达的楼层数是我们自己输入的;但每次都是会变化的(需要解决的一个问题),所以在一组数据输入之前我们不知道它到底会在那些楼层停留;​

2.在我们知道到达的楼层号时我们需要判断他是上升还是下降的;​​

解决方法:​

1.既然我们不知道到底会在那个楼层停留,但同时我们要保存到达的楼层号,所以vector是我们的一个好帮手;----这样不管我们到的楼层数有多少都可以往里面塞;​

2.既然我们已经保存了楼号我们用后面一个楼层号减去前面的一个楼层号,用他的正负来判断上升还是下降(正为上升,负为下降);​​

#include <iostream>

#include <cmath>

#include <vector>

using namespace std;int main()

{ 

   int n; 

while(cin>>n&&n!=0) 

    {  

        int i;  

        int time=0; 

       vector point;  

      int x,t; 

      point.push_back(0);  

for(i=0;i<=n-1;i++) 

 {   

       cin>>x;   

        point.push_back(x);  

} 

 for(i=0;i<=n-1;i++)  

{  

     t=point[i+1]-point[i];    

  if(t<0)   

     time+=abs(t)*4;      

  else     

     time+=t*6;  

}  

time+=5*n;  //每到一个楼层停留五秒

cout<<time<<endl; 

} 

return 0;

}

这样这题就OK了!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值