03-树3 Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 3030) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to NN). Then 2N2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

在参考了网上的相关资料后,得出了利用先序遍历和中序遍历得出后序遍历结果的方法。
网上给的是C++,相当于我翻译成了Java。


import java.util.*;

/**
 * Created by 凤凰院凶真 on 2017/4/9/0009.
 */
public class Main {

    private static Scanner in;
    private static Queue<Integer> queue=new LinkedList<Integer>();//得出结果存在队列里,在出列的时候进行判断
    public static void postOrder(int[] middle,int[] pre,int l){
        if(l==0){
            return ;
        }
        int value=pre[0];
        int rootIndex=0;
        for(;rootIndex<l;rootIndex++){
            if(middle[rootIndex]==pre[0])
            break;
        }
        postOrder(middle,Arrays.copyOfRange(pre,1,pre.length),rootIndex);
        postOrder(Arrays.copyOfRange(middle,rootIndex + 1,middle.length),Arrays.copyOfRange(pre,rootIndex + 1,pre.length),(l-rootIndex-1));
        queue.offer(value);
        return;
    }
    public static void main(String[] args) {
        in=new Scanner(System.in);
        int num=Integer.parseInt(in.nextLine()); 
        //System.out.println(num);
        int[] preOrder=new int[num];
        int[] middleOrder=new int[num];
        Stack<Integer> stack =new Stack<Integer>();
        for (int i = 0,p=0,m=0; i <2*num ; i++) {
            String s=in.nextLine();
            if(s.length()==6){//push的为一位数
                stack.push(Integer.parseInt(s.substring(5,6)));
                preOrder[p]=Integer.parseInt(s.substring(5,6));
                p++;
            }
            if(s.length()==7){//push的为两位数。这里应该有更好的输入方法
                stack.push(Integer.parseInt(s.substring(5,7)));
                preOrder[p]=Integer.parseInt(s.substring(5,7));
                p++;
            }
            if(s.length()==3){//pop的顺序即为中序遍历
                middleOrder[m]=(int)stack.pop();
                m++;
            }
        }
        postOrder(middleOrder,preOrder,num);
       for(int i=0;i<num;i++){
    	   if(i==0){//第一个不输出空格,之后的输出空格加数据
    		   System.out.print(queue.poll());
    	   }
    	   else{
    		   System.out.print(" "+queue.poll());
    	   }
       }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值