HDU 3371 Connect the Cities

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10597    Accepted Submission(s): 3007


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
  
  
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
  
  
1
 

Author
dandelion
题目大意:
在2100年,海平面上升,有许多岛屿被淹没了,现在有n座城市,政府想建一些路将他们连通起来,并且花费要尽量少,给你n座城市,m条可选路径,并且有k个子连通城市,每个中有t座城市是相互连通的。
这题略坑,一开始用G++提交的TLE,同样的代码换C++编译器提交却AC了,只有杭电上会出现这样的情况吧,它后台用的是微软的环境。
这题听说有重边,我没考虑,因为我用的是kruskal算法,这题用prim做效率会高点。
下面是kruskalAC代码
//prim+堆优化,以九度OJ 1347为例
//http://ac.jobdu.com/problem.php?pid=1347
#include<cstdio>
#include<algorithm>
const int L=100005;
struct node{int s,y,w;}edge[L];
int Fa[L],n,m;
void init()//初始化并查集
{
    for(int i=0;i<=n;i++) Fa[i]=i;
}
int Find(int x)//查询属于哪个集合,并直接拜“祖宗”为师
{
    if(Fa[x]==x) return x;
    else return Fa[x]=Find(Fa[x]);
}
void unite(int x,int y)//合并x,y两个元素
{
    x=Find(x);y=Find(y);
    if(x==y) return ;
    Fa[y]=x;
}
bool same(int x,int y)//【判断是否属于同个集合
{
    return Find(x)==Find(y);
}
bool cmp(node a,node b)
{
    return a.w<b.w;
}
int main()
{
    int T,k,t;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<m;i++)
            scanf("%d%d%d",&edge[i].s,&edge[i].y,&edge[i].w);
        init();
        int sum=0,cnt=0;
        for(int i=0;i<k;i++)
        {
            int x,y;
            scanf("%d%d",&t,&x);
            for(int j=2;j<=t;j++)
            {
                scanf("%d",&y);
                if(!same(x,y)) unite(x,y),cnt++;
            }
        }
        std::sort(edge,edge+m,cmp);
        for(int i=0;i<m;i++)
        {
            if(cnt==n-1) break;
            if(!same(edge[i].s,edge[i].y))
            {
                unite(edge[i].s,edge[i].y);
                sum+=edge[i].w;
                cnt++;
            }
        }
        //printf("%d\n",cnt);
        if(cnt!=n-1) printf("-1\n");
        else printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值